Question Status

Verified
Lyka Tasis asked a question on 2 Mar 2013 3:35 AM

Hello,

I have a custom service I use to import data. I'm having difficulties since its throwing the following error in the Queue Manager:

The request failed with the following error: Failed to logon to Microsoft Dynamics AX.
View the exception log for more details.

I tried Refreshing the WCF Configuration in the Configuration Utility, but no luck. 

Any ideas?

Thanks,

Lyka Tasis

Reply
Verified Answer
Lyka Tasis responded on 5 Mar 2013 10:09 PM

Hi Mukesh,

I am using File System Adapter.

Hi Tommy Skaue,

No, I don't intend to use this outside the local network domain. But thanks to the question, it serves as my lead.

I have a standalone AX 2012 in my laptop, I am not connected to our domain in the time of testing and I guess that's the reason why the BC service account cannot logon that time.

Reply
Suggested Answer
Mukesh Hirwani responded on 5 Mar 2013 10:13 PM

Next to adapter field there is a configure button, Adapter configuration form will come up. Check Use default owner for Administrators group and select Admin in the field list. Reactivate port n try..

Mukesh Hirwani
http://mukesh-ax.blogspot.in/ 

   

Reply
Mukesh Hirwani responded on 2 Mar 2013 10:59 AM

Are u sending user id to create the record.. Make user the User you provide has correct set of permissions.

Mukesh Hirwani
http://mukesh-ax.blogspot.in/ 

   

Reply
Lyka Tasis responded on 2 Mar 2013 11:06 PM

Hi Mukesh,

I only identify the Action for my custom service. The Message Id, SourceEndpoint, DestinationEndpoint, and SourceEndpointUser - I did not specify. Plus, I am only testing my service via Job.

Reply
Mukesh Hirwani responded on 3 Mar 2013 2:03 AM

which adapter u r using??

Mukesh Hirwani
http://mukesh-ax.blogspot.in/ 

   

Reply
Tommy Skaue responded on 3 Mar 2013 8:29 AM

Is this a custom service you intend to use outside the local network domain?

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Verified Answer
Lyka Tasis responded on 5 Mar 2013 10:09 PM

Hi Mukesh,

I am using File System Adapter.

Hi Tommy Skaue,

No, I don't intend to use this outside the local network domain. But thanks to the question, it serves as my lead.

I have a standalone AX 2012 in my laptop, I am not connected to our domain in the time of testing and I guess that's the reason why the BC service account cannot logon that time.

Reply
Suggested Answer
Mukesh Hirwani responded on 5 Mar 2013 10:13 PM

Next to adapter field there is a configure button, Adapter configuration form will come up. Check Use default owner for Administrators group and select Admin in the field list. Reactivate port n try..

Mukesh Hirwani
http://mukesh-ax.blogspot.in/ 

   

Reply