AX 2012 R2 useless AIF error message

This question is answered

Hi,

I have created my own document service totally based on custom tables. Then I created an inbound port using the FileSystemAdapter pointing to a directory on the AOS.

Now I can put an XML into this directory and let the AIF pick it up.

I now have the message in the AIF message queue:

Direction: Inbound

Status: Error

Error message: Function 'Global::typeId2ExtendedTypeId' must be called with an extended data type.

Stack trace

\Classes\AifWcfSendAdapter\sendMessage                                   line 65

\Classes\AifGatewaySendService\sendMessage                           line 34

\Classes\AifRequestProcessor\callAosServiceOperation             line 62

\Classes\AifRequestProcessor\processRequest                           line 32

\Classes\AifInboundProcessingService\processRequest            line 34

...

Line 65 of AifWcfSendAdapter.sendMessage():

responseMessage = wcfClient.ProcessRequest(requestMessage, configFilePath, endpointConfigurationName, addressOverride, throwOnFaultResponse);

wcfClient is of type Microsoft.Dynamics.IntegrationFramework.Adapter.WcfClient

So, something goes wrong in there.

Has anybody faced the same error and found a solution?

Thanks in advance,

Andy

Verified Answer
  • Yeah. I got it. Thanks to the guys in this thread: community.dynamics.com/.../199013.aspx I tried Net Reflector (trial version) to find the cause of the problem.

    There was an error in an upgraded method (wrong usage of extendedtypenum() / extendedtypeid()). Never would have thought about this one...

All Replies