Question Status

Verified
Giuseppe Caradonna asked a question on 15 Mar 2013 6:47 AM

Hi all,

I'm new in AX 2012. I've a environment with AX 2021 FP CU3 with a vertical solution installed (VAR layer).

When I try to deploy the SalesInvoice.report I receive this error:

Make sure that Microsoft Dynamics AX Business Intelligence Components are installed on the SQL Server Reporting machine and veriFy that SQL Server Reporting Services is configured correctly matching the report server configuration in the Microsoft Dynamics AX client.

This is the only report that I don't able to deploy. I've tried to change report property from "static" to "not static" but the result is the same.

Which are the objects that are involved in this report so that I can delete them from the vertical solution layer? Eg. SalesTmp table, SalesInvoiceDP class...

Thanks and regards.

Giuseppe Caradonna

Reply
Verified Answer
Giuseppe Caradonna responded on 25 Apr 2013 9:00 AM

Hi all.

TVH has provided me the xpo with all the objects involved in the procedure that generates the SalesInvoice Report and now I can deploy it.

Reply
Frank Guaragna responded on 28 Mar 2013 9:35 AM

Ciao Giuseppe,

I have the same error. Have you found a solution yet? Are you using TVH as your vertical solution?

Reply
Giuseppe Caradonna responded on 28 Mar 2013 9:41 AM

Hi Frank.

Yes, I'm using TVH vertical solution and I have not yet found a solution but I opened a ticket addressed to them.

Reply
Girija Shankar Beuria responded on 28 Mar 2013 3:59 PM

What is the SSRS version ?

Reply
Giuseppe Caradonna responded on 29 Mar 2013 3:52 AM

The SSRS version is 10.50.2550.0

Reply
Jimmy Liu responded on 1 Apr 2013 12:22 AM

Hi Giuseppe,

A few question to follow up:

1. Does this issue happen on all reports - can you try to deploy a dynamic RDCE report like assetlisting?

2. Is SSRS configured correctly - can you verify the report folder correctly on SRSServers form and both report server and report manager is accessible?

3. Does the SSRS services user and execution user match the BC user?

4. Does powershell deployment work?  

Reply
Dick Wenning responded on 1 Apr 2013 1:18 AM

can you normaly start SSRS?

are there multiple AOS in your environment?

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Giuseppe Caradonna responded on 2 Apr 2013 12:20 AM

@JimmyLiu these are my answers:

1) This problem only occurs with this report;

2) SSRS is configured correctly: both report server and report manager are accessible;

3) SSRS services user and execution user are the same and are the BC user;

4) With powershell all reports are deployed except SalesInvoice.

@DickWenning, yes, I can normaly start SSRS and in my environment I've two AOS.

At this point I think that there is a bug in the report becouse all other works correctly.

Reply
Verified Answer
Giuseppe Caradonna responded on 25 Apr 2013 9:00 AM

Hi all.

TVH has provided me the xpo with all the objects involved in the procedure that generates the SalesInvoice Report and now I can deploy it.

Reply