Question Status

Verified
Zach Henry asked a question on 19 Mar 2013 7:00 AM

I am trying to install DMF 2.0. Upon initial attempt the Prerequisite validation I had an error that said I need .NET framework 4.5. So I have now installed that. Now when I run the Prerequisite validation I'm getting two errors that state the following:

Gacutil utility for registering .NET 3.5 assembly

 

Gacutil utility for registering .NET 4.0 assembly

 

I haven't been able to locate any information on this specific issues. Any help would be greatly appreciated.

 

Thank you,

 

Z

Reply
Sebastian Cuartas responded on 19 Mar 2013 7:36 AM

i have the same error :S

i´ll let you know if i solve this soon

Reply
Verified Answer
Zach Henry responded on 19 Mar 2013 7:37 AM

Glad its not just me. I'll do the same.

Reply
Zach Henry responded on 19 Mar 2013 10:56 AM

I have been able to get the prerequisite validation to pass. I was fortunate to have a duplicate server. So I had somewhere to copy these files from. But what I found was the installing 4.5 will remove the previous .NET version files (This is on the KB for 4.5). So I had to copy the "gacutil.exe" and gacutil.exe.config" files to the following locations:

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin

and

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin\NETFX4.0 Tools

Leaving a copy of these files in each location fulfilled the validation.

Reply
Sebastian Cuartas responded on 20 Mar 2013 1:38 PM

thats the only solution you found? jeje i dont have those files so i am still looking for the validation to pass :S

Reply
Sebastian Cuartas responded on 21 Mar 2013 9:54 AM

as Zach said, replacing these files

cid-5ae3f43b1d873a75.office.live.com/.../gacutil.zip

into this paths:

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin

and

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin\NETFX4.0 Tools

it would pass the validation process.

Reply
Fadi Ghrawi responded on 23 Mar 2013 6:24 AM

Worked like charming , thanks

Reply
Guillaume DURAND - Lyon responded on 1 Apr 2013 9:28 AM

I have just the folowwing error "Gacutil utility for registering .NET 3.5 assembly".

And the workaround is not working for me.

Greets,

Guillaume

Reply
Stuart Honour responded on 25 Apr 2013 7:21 AM

Installing On Windows 2012 and i get the following any ideas?

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.NullReferenceException: Object reference not set to an instance of an object.

  at DmfSetup.ValidatePrerequisites.GetGacUtilPath(String registryHive, Hashtable versions, GacutilType gacutilType)

  at DmfSetup.ValidatePrerequisites.GetMicrosoftSDKInstallFolder(GacutilType gacutilType)

  at DmfSetup.ValidatePrerequisites.CheckMicrosoftSDKsExists()

  at DmfSetup.DmfMain.btnNext_Click(Object sender, EventArgs e)

  at System.Windows.Forms.Control.OnClick(EventArgs e)

  at System.Windows.Forms.Button.OnClick(EventArgs e)

  at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

  at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

  at System.Windows.Forms.Control.WndProc(Message& m)

  at System.Windows.Forms.ButtonBase.WndProc(Message& m)

  at System.Windows.Forms.Button.WndProc(Message& m)

  at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

  at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

   Assembly Version: 4.0.0.0

   Win32 Version: 4.0.30319.18033 built by: FX45RTMGDR

   CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

----------------------------------------

Setup

   Assembly Version: 1.0.0.8

   Win32 Version: 1.0.0.8

   CodeBase: file:///C:/Software/DataImportExportFramework/DataImportExportFramework/Setup.exe

----------------------------------------

System.Windows.Forms

   Assembly Version: 4.0.0.0

   Win32 Version: 4.0.30319.18037 built by: FX45RTMGDR

   CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

   Assembly Version: 4.0.0.0

   Win32 Version: 4.0.30319.18022 built by: FX45RTMGDR

   CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System

   Assembly Version: 4.0.0.0

   Win32 Version: 4.0.30319.18033 built by: FX45RTMGDR

   CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

Accessibility

   Assembly Version: 4.0.0.0

   Win32 Version: 4.0.30319.17929 built by: FX45RTMREL

   CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

   <system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Reply
Neil Millinson responded on 25 Apr 2013 7:58 AM

I too have the validation pre-req failure on "Gacutil utility for registering .NET 4.0 assembly" when trying to install the AOS component on the AOS server.

I have copied the gacutil and gacutil.exe.config into the following paths:

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin

and

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin\NETFX4.0 Tools

But still get the error.  Any help would be gratefully recieved

Reply
Paul Mayle responded on 30 Apr 2013 9:20 AM

Hi Neil,

I had to make sure there was a space in between "NETFX" and "4.0" in my path:

  "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin\NETFX 4.0 Tools\"

I have also seen other users report slightly different paths, so you could try these if the above doesn't work:

   "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0a\Bin\NETFX 4.0 Tools\"

   "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1\Bin\NETFX 4.0 Tools\"

Also note that if you installed the SDK on a different drive (other than C), it may be checking for the gacutil on that drive.

Good luck!

-P

Reply
Verified Answer
Zach Henry responded on 19 Mar 2013 7:37 AM

Glad its not just me. I'll do the same.

Reply