Ax 2009 Closed when trying to change AX language

This question is answered

when select dynamics ax -->options to change ax language ax stop immediately and the following error appear in the event viewer

Faulting application name: Ax32 rollup 8.exe, version: 5.0.1500.6491, time stamp: 0x4f611504
Faulting module name: Ax32 rollup 8.exe, version: 5.0.1500.6491, time stamp: 0x4f611504
Exception code: 0xc0000005
Fault offset: 0x00224b8f
Faulting process id: 0xcf4
Faulting application start time: 0x01ce28623bab6cae
Faulting application path: F:\rollup 8 client\Client\Bin\Ax32 rollup 8.exe
Faulting module path: F:\rollup 8 client\Client\Bin\Ax32 rollup 8.exe
Report Id: a6cb343a-9455-11e2-a237-00155d01de00

 

Please this an urgent issue any advice

Verified Answer
  • i solved my issue by replace my application folder from another application folder which is are correct and working successfully then compile system from upgrade check list.

    then sync database.

    Thanks for your help

    ANDIRUDI, Tommy

All Replies
  • Normally, a sudden crash of the client is a symptom of a bad client cache or versions of the components not being on the same build.

    The client cache is normally under the folder path "%appdata%\..\Local\" (Windows 2008) and the file extension is AUC. Close the client and delete the files. They will be rebuilt by the client when it starts if needed.

    The components you should make sure are aligned are Client, AOS-Service and Application (SYS+SYP).

    The help dialog will reveal Client and Application, but not the AOS-Service (by default). You can head over to the Service binaries (dlls) where the service is installed, sort them by date and find one with the Microsoft.Dynamics namespace/nameconvention, right-click, Properties, Details and have a look at the version. It should be aligned with the version of the Client and application.

    Another thing that might cause sudden crash is the UserData being incompatible with the actual current application metadata. You will find userdata within the AX Client, but removing ALL userdata will probably result in frustrated users. ;-)

    Try to narrow down what exact element has invalid userdata, and remove the userdata for that exact element.

    Good luck!

    Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

  • Another one could be that the system isn't compiled successfully. Do a full recompile but NOT in AOT. Go the way using the menu (somewhere in System Administration).... and maybe you have to restart AOS after the compile.

  • i solved my issue by replace my application folder from another application folder which is are correct and working successfully then compile system from upgrade check list.

    then sync database.

    Thanks for your help

    ANDIRUDI, Tommy