Question Status

Suggested Answer
Narayan PS asked a question on 27 Mar 2013 1:53 AM

AX 2012 R2 client configuration utility is not opening

And when looking in to the event viewer log it shows the following error

Faulting application name: AxCliCfg.exe, version: 6.0.947.0, time stamp: 0x4e098703
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e21213c
Exception code: 0xe0434352
Fault offset: 0x000000000000cacd
Faulting process id: 0x1244
Faulting application start time: 0x01ce2abd220101d7
Faulting application path: C:\Program Files\Microsoft Dynamics AX\60\BusinessConnector\Bin\AxCliCfg.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 601ba348-96b0-11e2-afc2-5cf9dd759361

Any idea about why client configuration utility is not opening

Reply
Suggested Answer
Tommy Skaue responded on 17 Dec 2013 1:17 PM

Your components are not properly upgraded. The error says your AXCliCfg is of the RTM version and not the R2 version.

Reinstall the business connector and make sure it is upgraded to the correct version:

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
André Arnaud de Calavon responded on 27 Mar 2013 2:19 AM

can you also specify the operating system you are using? Which version of Windows?

kind regards,

André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

Reply
Narayan PS responded on 27 Mar 2013 2:20 AM

hi,

I am using Windows 7 professional 64- bit OS

Reply
Søren Rasmussen responded on 27 Mar 2013 6:11 AM

2 things to try:

a) reinstall client

b) reinstall .net framework

Reply
Dick Wenning responded on 27 Mar 2013 2:34 PM

did you try run as administrator

it can work out sometimes

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Narayan PS responded on 28 Mar 2013 2:44 AM

I have tried to completely remove AX and re install everything still  it dint work

Also tried running as administrator still the configuration utility is not shown

????

And this is what is receive in the event viewer which shows the application client configuration utility crashes

Reply
Dick Wenning responded on 28 Mar 2013 12:35 PM

Can you ping the AOS server?

can you open a telnet session to the AOS?

does the AX client it self work ok?

O have seen issues when SQL server was down, the server configuration took for ever to start.

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Douglas Noel responded on 17 Dec 2013 12:41 PM

Hi all,

I've had exactly the same (similar) problerm starting the Ax32.Exe client (but only on some machines). Didn't do anything beside installing a "new small program"

Can you please check if the Length of your Enviroment variable PATH exceeds 2048 ????

I never had beliebed that - but this was the real problem in my personal case.

After cutting the path - immediately everything runs fine.

This seems to be a known problem - even SAP client has similarentires within support database.

regards Douglas

Reply
Suggested Answer
Tommy Skaue responded on 17 Dec 2013 1:17 PM

Your components are not properly upgraded. The error says your AXCliCfg is of the RTM version and not the R2 version.

Reinstall the business connector and make sure it is upgraded to the correct version:

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply