Power View Report Data Source Library not being deployed in Enterprise Portal...

This question is answered

I am trying to setup Power View with AX now that SQL 2012 CU4 supports power view with multidimensional models.  According to technet documentation, the 'Power View Reports' document library should automatically be deployed in enterprise portal.

Technet documentation:

To create a data source

  1. Go to the Power View Reports folder of your Enterprise Portal site. The URL for this folder is typically http://<SharePointServerName>/sites/DynamicsAX/Power%20View%20Reports.

    NoteNote

    Data source connections are created automatically when you deploy role center pages to Enterprise Portal. You can browse the Power View Reports folder to see the data source connections that already exist. For information about creating and deploying role center pages, see How to: Create a Role Center.

There is no 'Power View Reports' document library or existing data source connections when I deploy the default enterprise portal setup. I can verify that they do exist on the Contoso VPC but I cannot seem to duplicate the setup.  

Here is an example from the Contoso VM:

Do I need to create the document library and data sources manually on my implementation?

Verified Answer
  • I believe the document library is created automatically when you deploy the PowerViewDataSourceGeneratorPV page definition.  I believe this also deploys the data sources for the Accounts Payable, Accounts Receivable, GL, and Sales cubes.  (To connect to the other cubes, you'll need to create a data source manually, as documented here: technet.microsoft.com/.../jj933492.aspx).

    Sorry I wasn't able to help you resolve your issue,

    Sally

All Replies