AX2012 R2 MasterPlanning Cinsistency Check

This question is answered

So I just ran the Master Planning Consistency check and get 300+ errors which are all the same:Item Number XXXXXXXXm priority must be greater than zero. The only mention of a priority that I can find in any parameters is on a Formula. Given that my client is not using process manufacturing, what could be causing this error?

Verified Answer
  • In AX2012 the tables and fields depending on a configuration key are not removed when you disable a configuration key or license key. All tables and fields are now blanked. So the value in the field is 0. The validateField method on the ReqItemTable only checkes if the field has a value greater than zero, even when the configuration key is disabled.

    I think for the Product team "process manufacturing: "Back to the  drawing board."

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

All Replies
  • Hi,

    I suggest to disable process manufacturing if you are not using it, it caused my client many issues and pubic sector as well.

    you can disable that from System administration > Setup > Licensing > License information -> modules -> and delete the password for process manufacturing.

    Regards,

    Bilal

  • Hi Michael,

    The error is indeed caused by functionality from process manufacturing. The Item coverage table has this check. When you are only using standard AX the field default priority has no value. This field is checked without any additional conditions.

    In my optinion this is a minor bug.

    You can either disable process manufacturing as Bilal mentioned or leave it as it is now. It is also possible to fill this field for all records with the value '1' and the validation is succesful as well.

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • Well, we all thought th esame thing, which is consistent.

    However, you are not allowed to desellect Process Manufacturing in AX2012 apparently, and it looks like we eith erignore it, or force a default value into the Item Coverage for every Item!

  • Hi Michael,

    Ax allow you to disable Process Manufacturing  if you are not using it, and I have done that already, are you getting any error?

    Regards,

    Bilal

  • No error as such, but I am unable to deselect Process Manufacturing. I can deselect the two sub nodes, but not Process Manufacturing itself.

     

  • How were you able to disable it?

  • System administration > Setup > Licensing > License information -> Feature sets

    and then remove the License code, then Sync the database.

  • I was able to remove those, and sync the database, re ran the Master [planning consistency check, but stil get the error!

    Back to the drawing board I guess.

     

     

  • In AX2012 the tables and fields depending on a configuration key are not removed when you disable a configuration key or license key. All tables and fields are now blanked. So the value in the field is 0. The validateField method on the ReqItemTable only checkes if the field has a value greater than zero, even when the configuration key is disabled.

    I think for the Product team "process manufacturing: "Back to the  drawing board."

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • Case#113081910673905 raised with Microsoft.

    Thanks for your inputs!