Dynamics connector V3 for AX 2012 R2 configuration problem

This question is not answered

Hello,

I'm trying to configure an integration for AX 2012 R2 (kernel version 6.2.1000.2265 and app version 6.2.158.0) but when I'm refreshing services on the Microsoft Dynamics AX 2012 Adapter Configuration window I get an error.

The error is:

---------------------------

Application Exception

---------------------------

Object reference not set to an instance of an object.

---------------------------

OK  

---------------------------

The content of log  is :

INFO TID:1 [2013-09-06T04:31:21.4449216-05:00]: Tracing for Assembly: Microsoft.Dynamics.Integration.Adapters.AX2012.Configuration, FileVersion = 3.0.430.1

ERROR TID:1 [2013-09-06T04:31:21.5074160-05:00]: Application Exception

--- Exception Dump ---

Caught Exception: [Microsoft.Dynamics.AX.Framework.Services.Client.MetadataServiceException] Exception occurred on the metadata service on client or server. See exception details below:

>Object reference not set to an instance of an object.

Stack trace:

  at Microsoft.Dynamics.AX.Framework.Services.Client.ServiceClientHelper.InvokeChannelOperation[TResult,TChannel](IServiceClient`1 client, Func`2 operationInvoker, Func`2 exceptionWrapper)

  at Microsoft.Dynamics.AX.Framework.Services.Client.MetadataServiceProxyFactory.<>c__DisplayClass3e.<CreateServiceGroupMetadataProxy>b__3c()

  at Microsoft.Dynamics.AX.Framework.Services.Client.MetadataServiceProxyFactory.CreateServiceGroupMetadataProxy(String serviceGroupName)

  at Microsoft.Dynamics.AX.Framework.Services.Client.MetadataCache.<.cctor>b__38(String mainKey)

  at Microsoft.Dynamics.AX.Framework.Services.Metadata.MetadataAccessorBase`2.GetItem(TKey key)

  at Microsoft.Dynamics.AX.Framework.Services.Metadata.Caching.ItemCache`2.<>c__DisplayClassc.<GetItemCustom>b__b()

  at Microsoft.Dynamics.AX.Framework.Services.Metadata.Caching.CacheBase.CacheRead(ICacheReadArgs cacheReadArgs, Action tryReadAction, Action readThroughAction)

  at Microsoft.Dynamics.AX.Framework.Services.Metadata.Caching.ItemCache`2.GetItemCustom(TKey key, Func`2 itemAccessor)

  at Microsoft.Dynamics.AX.Framework.Services.Client.MetadataCache.GetServiceGroupMetadata(String serviceGroupName)

  at Microsoft.Dynamics.AX.Framework.Services.Client.PortInfo.GetServices()

  at Microsoft.Dynamics.Integration.Adapters.AX.Common.AX2012Utility.RetrievePorts()

  at Microsoft.Dynamics.Integration.Adapters.AX2012.Configuration.Main.ResetPortsAndServices()

Inner Exception: [System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]] Object reference not set to an instance of an object.

Stack trace:

Server stack trace:

  at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)

  at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)

  at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

  at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

  at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

  at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

  at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

  at Microsoft.Dynamics.AX.Framework.Services.Metadata.Service.IAxMetadataService.GetServiceGroupMetadataByName(String[] serviceGroupNames)

  at Microsoft.Dynamics.AX.Framework.Services.Client.ServiceClientHelper.InvokeChannelOperation[TResult,TChannel](IServiceClient`1 client, Func`2 operationInvoker, Func`2 exceptionWrapper)

Of course, I imported the xpo for R2 and all services are configured as is specified on the documentation. The DynamicsConnectorDefaultServices Inbound port is activated.

Any idea what is going on?

Thanks a lot!

All Replies
  • blogs.technet.com/.../connector-for-microsoft-dynamics-v3-3-0-430-1-refresh-available-now.aspx

    Maybe this new version is of any help?

  • No, I I used the newest version but It does not help. The above message  cams from V 3.0.430.1 but I noticed the same behavior with the previous version as well.

  • redeploy your meta data service

  • Can you please provide steps for redploying the meta data service?

    Cheers,

    Dillon

  • Can you please provide steps for redploying the meta data service?

  • @Dillon:

    is this issue resolved for you? I am facing the same issue with the Dynamics Connector while configuring AX 2012 adapter. Can you please let me know if any resolution found.

    Thanks

    Anand

  • Hi Anand,

    With the latest connector there is no need to import and deploy the .XPO file...I ended up stripping all customisations from the xpo, restarting the installation process with the latest connector download from the connector team and this seems to now work..mostly.

    There are still heaps of small bugs and issues with the integration, but it serves most of its purpose o.k.

    Latest connector as of this date:  blogs.msdn.com/.../connector-for-microsoft-dynamics-v3-cu-2-released.aspx

    Hope this helps mate.

    DB