Question Status

Suggested Answer
Raúl Llorente Peña asked a question on 9 Jul 2012 10:42 AM

Hello, I've installed an additional SQL Server 2008 Reporting Services following the steps stated at: http://technet.microsoft.com/en-us/library/hh389760.aspx

So, new instance, new axc file, config files of SSRS edited, etc.

I access the reports folder with no problem, but when I try to execute one of them (per example, SysCompanySize.Report, that is Analysis Services-independant), I always get the error:

  • AX_CompanyName (rsReportParameterProcessingError)

 

I've checked the accounts of new SSRS instance, and i's ok, it runs under Ax Business Connector Proxy account.

I think the issue comes from Configuration file.

In the document of installing multiple SSRS instances, there's a step called "Create a new Microsoft Dynamics AX configuration [AX 2012]" (link: http://technet.microsoft.com/EN-US/library/hh389774). I've created a config file an put it in the bin folder of Report Server folder, naming it as "Microsoft.Dynamics.AX.ReportConfiguration.axc". But SSRS doesn't use it. I've renamed the file (so I was not loaded) or put several different Ax configurations in that file; SSRS always use the actual configuration used in Ax 2012 Configuration Utility.

If (always using Axapta Configuration Utility) I put Business Connector against original AOS, the report works; If I put Business Connector against new AOS, the error arises.

Any help? Thanks in advance!!

 

At this point, I must note that Analysis extensions, Reporting extensions and Business Connector were installed using the read-from-registry option. But, being those new instances, they should catch the new files... Am I right?

 

 

Reply
Suggested Answer
Stefan Quinn responded on 10 Jan 2013 7:27 PM

You will get this message each time you restart SSRS and run a report for the first time. If you run the report a second time it will work.  To fix this do the following:

Locate rssrvpolicy.config file in C:\Program Files\Microsoft SQL Server\<>\Reporting Services\ReportServer

Search the document for the following text: Report_Expressions_Default_Permissions

In this block replace PermissionSetName="Execution" with PermissionSetName="FullTrust"

Save changes, restart the SSRS server and test a report

Reply
Tarun Godhwani responded on 9 Jul 2012 9:50 PM

Hi Raul,

We had a similar environment (AX 2012) and did the following.

After creating a new SSRS instance, we need to create a new configuration ID in AX under the following path:

System Administration --> Setup --> Business Intelligence --> Reporting services --> Report Servers:

Set up the new configuration ID as the default and enter the name of the report folder. Because we created a new folder, we chose the option 'Create new folder'. This will create the folder under Report manager URL.

we then went to the SSRS server and published all the reports under the new configuration ID (created above).

Command: 'Publish-AXReport –Id NewSSRSConfigID –ReportName *'

You can now test and check if the reports can be executed.

Hope the above helps.

P.S: we did not create a new AX configuration file (.axc) as you noted above. I believe this step is is not necessary.

Reply
Raúl Llorente Peña responded on 10 Jul 2012 12:07 AM

Tarun, of course we did so.

In the article, the 6th step is "Connect Microsoft Dynamics Ax to the new reporting services instances" (technet.microsoft.com/.../hh389773) and of course we followed its steps.

All the operations are being executed under administrator account.

But, we are now installing Ax 2012 FP client in SQL+SSRS+SSAS box, in order to test and try again the deployment of reports. We will report about results.

 

UPDATE:

When executing Company Size report from Explorer in Reports folder, same error as always appears.

But, when executing this same report from Ax, infolog message "Failed to logon to Microsoft Dynamics AX" appears.

Looking in event viewer:

 

Origen: Microsoft.Dynamics.AX.Frameworks.Controls

Event Id: 1000 (error)

 

Error al procesar el informe. (rsProcessingAborted)

Error al procesar el informe. (rsProcessingAborted)

Microsoft.Reporting.WinForms.ReportServerException
   en Microsoft.Reporting.WinForms.ServerReport.ServerUrlRequest(Boolean isAbortable, String url, Stream outputStream, String& mimeType, String& fileNameExtension)
   en Microsoft.Reporting.WinForms.ServerReport.InternalRender(Boolean isAbortable, String format, String deviceInfo, NameValueCollection urlAccessParameters, Stream reportStream, String& mimeType, String& fileNameExtension)
   en Microsoft.Reporting.WinForms.AsyncMainStreamRenderingOperation.RenderServerReport(ServerReport report)
   en Microsoft.Reporting.WinForms.AsyncRenderingOperation.PerformOperation()
   en Microsoft.Reporting.WinForms.ReportViewer.AsyncReportOperationWrapper.PerformOperation()
   en Microsoft.Reporting.WinForms.ProcessingThread.ProcessThreadMain(Object arg)

Error de ejecución de consulta para el conjunto de datos 'SysCompanySizeDS'. (rsErrorExecutingCommand)

Microsoft.Reporting.WinForms.ReportServerException


Se produjo una excepción en la ejecución de los metadatos de la consulta. La excepción es Se produjo un error en el servicio de metadatos del cliente o servidor. Consulte los detalles de la excepción que se indican a continuación:
>Unable to log on to Microsoft Dynamics AX..

Microsoft.Reporting.WinForms.ReportServerException


Se produjo un error en el servicio de metadatos del cliente o servidor. Consulte los detalles de la excepción que se indican a continuación:
>Unable to log on to Microsoft Dynamics AX.

Microsoft.Reporting.WinForms.ReportServerException


Unable to log on to Microsoft Dynamics AX.

Microsoft.Reporting.WinForms.ReportServerException

Any help or hint?

Reply
ACM responded on 12 Jul 2012 7:33 PM

Hola,

Revisa tu log de RS. Checa que haya conexión al AOS correcto, y no sé si te sirva que tu Business Connector tenga derechos dentro de tu instancia de Report Server

Reply
Khalid Omari responded on 9 Sep 2012 2:19 AM

I have come across this issue before and got  it solved,

The client had 2 SSRS instances , all reports deployed and the reports worked only on Original MSSQLSERVER instance but didn't work on the new manually installed SSRS instance.

i was receiving multiple errors whenever i tried to run a report i got:  " Failed To Log on to DynamicsAX" and sometimes " Company [[CEU]] doesn't exist ... or "Reporting framework error: Dynamic packed query not found"..

the solution i have tried i :

1- checked the Active local and Business connector configuration and made sure they are assigned to the correct AOS configuration and it's Important to Refresh WSDL (WCF) configuration.

2- double checked the configuration of Multiple SSRS Instances and re-applied this step technet.microsoft.com/.../hh389774

i know i did it before when the first time applied the New SSRS instance , but i re- created AX Config file and the i now can run any report from any company without any errors.

Khalid

Reply
Suggested Answer
Stefan Quinn responded on 10 Jan 2013 7:27 PM

You will get this message each time you restart SSRS and run a report for the first time. If you run the report a second time it will work.  To fix this do the following:

Locate rssrvpolicy.config file in C:\Program Files\Microsoft SQL Server\<>\Reporting Services\ReportServer

Search the document for the following text: Report_Expressions_Default_Permissions

In this block replace PermissionSetName="Execution" with PermissionSetName="FullTrust"

Save changes, restart the SSRS server and test a report

Reply