Question Status

Unanswered
Gabor Fulop asked a question on 21 Nov 2012 12:07 PM

Employers must reimburse employees for business expenses no matter how long it takes them to be entered into AX.  According to existing functionality, the "Transaction Date" in the expense report line is used for determining which period the expense report line should be posted.  If the period is closed, the expense report cannot be posted.  As a work around, the expense report transaction dates could be changed to a current date, but this will make reconciliation by travelers far too tedious and will result in differences between attached receipts and the report itself.  This is not acceptable from a regulatory perspective.  Is there some way to post an expense report with transactions from a prior period into a current one while retaining the correct transaction date?

Reply
EDGE responded on 19 Dec 2012 10:49 AM

Did you ever solve this one? We're running into the same issue.

Reply
Gabor Fulop responded on 19 Dec 2012 11:27 AM

Hello,  We have logged a bug and Product Development asked some questions about a proposed resolution.  Apparently we were not the first ones to have this issue so hopefully they will provide a fix in a reasonable timeframe.

Reply
Shantanoo Govilkar responded on 2 Jan 2013 10:29 AM

Expenses should be booked on a daily basis by the employees for reimbursement of the same. In an actual scenario, this cannot be implemented due to many reasons. So customize by including an actual date of travel on the form and the date expense report was submitted without any validation with the transaction period.  Date of submission of expense report will be the actual date on which it can be posted.

Reply
EDGE responded on 2 Jan 2013 7:54 PM

Barry, adding a field for tracking the transaction date doesn't work for accrual accounting. Expenses should be posted to the period in which they were incurred. Adding an additional column doesn't fix the problem with expense transactions posting to the wrong period. This is a Microsoft bug that needs to be fixed.

Reply
Gabor Fulop responded on 3 Jan 2013 1:19 PM

Dear Jim and Shantanoo,  Thank you for your comments.  If Microsoft does not fix this, we plan to do something similar to what Shantanoo (a.k.a. Barry) describes.  This is the least invasive customization to fix a major design flaw and is in-line with what Microsoft suggested too.  Microsoft admitted that they dropped this functionality from 2009 due to resource constraints.  

This is today's update to the recorded bug, so I will continue to hope for resolution within 4-6 weeks, but may need to prepare for customizing:

"Unfortunately, Development is still figuring out what they want to do with this one.  We have actually had 3 incidents open reporting this same problem since you came in so we have active discussion going on how to handle all the scenarios that are possible with automatic posting, workflow, etc….

We are making progress and something will be done to allow you to post into the open period rather than get an error but we are still discussing how it will handle."

Best regards,

Gabor

Reply
Sumit Potbhare responded on 26 Jun 2013 2:23 PM

Did you get the resolution for this issue. Can you please share this with me.

Sumit Potbhare | Lead Business Analyst - Dynamics AX for Retail

If this post helps you, Please verify this answer and earn Thank you Badge for yourself

====This posting is provided "AS IS" with no warranties, and confers no rights.====

Reply
Gabor Fulop responded on 26 Jun 2013 2:39 PM

Microsoft provided a hot fix, but it has not been tested yet; see note from Microsoft:

The hot fix for your issue has been packaged and placed on an HTTP site for you to download.

WARNING: This fix is not publicly available through the Microsoft website as it has not gone through full Microsoft regression testing.  If you would like confirmation that this fix is designed to address your specific problem, or if you would like to confirm whether there are any special compatibility or installation issues associated with this fix, you are encouraged to speak to a Support Professional in Product Support Services.        

Package:

-----------------------------------------------------------  

KB Article Number (s) : 2852252  

Language: All (Global)  

Platform: i386  

Location: ( hotfixv4.microsoft.com/.../463989_intl_i386_zip.exe )

NOTE: Be sure to include all text between '(' and  ')' when navigating to this hot fix location!

Thanks!

Reply
Sumit Potbhare responded on 26 Jun 2013 2:56 PM

Hi Gabor,

Thanks for the response. Actually what is our requirement is that the posting date should be the date on which the automatic posting workflow post the expense report. Can you suggest any easy way of achieving it?

Thanks in advance,

Sumit

Sumit Potbhare | Lead Business Analyst - Dynamics AX for Retail

If this post helps you, Please verify this answer and earn Thank you Badge for yourself

====This posting is provided "AS IS" with no warranties, and confers no rights.====

Reply
Gabor Fulop responded on 26 Jun 2013 3:02 PM

No, I do not know, but if the hot fix does what it is supposed to then it should be pretty close to what you are looking for.

Reply