Error while trying to deploy Dynamics AX 2009 SSRS reports

This question is not answered

I am trying to deploy reports using the Dynamics AX Reports deployment tool, the error I get is:

One or more libraries built with warnings. Please see MSBuild log at C:\Users\daxinstal\AppData\Local\Temp\2\tmpDF3E.tmp
Deployment failed unexpectedly with the message:
Not found
See the log file for further details.
The deployment log file can be found at "C:\Users\daxinstal\AppData\Local\Temp\2\tmpD8D3.txt"

The txt file contains:

Could not load file or assembly 'Microsoft.Dynamics.AnalysisServices, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.AppDomain.Load(String assemblyString)

My reports server has only the prerequisite software installed, and also Dynamics AX Reporting Services and .NET connector.

Prerequisite software installed:

  • Microsoft Visual Studio 2008 Shell Redistributable package - Isolated mode
  • Microsoft Windows SDK 7 (7.1)
  • Windows Installer 3.1 and Microsoft .Net 3.5.1 came already with Windows Server 2008 R2.
  • Installed Patch KB960158 on AOS server

In my reports server I am using Windows Server 2008 R2 Standard and SQL Server 2008 R2 for my database server and Reporting Services.

Any help would be much appreciated.

Thank you.

 

All Replies
  • One question: Reporting Extensions was installed correctly? SSRS reports are working from axapta(when you open the report from menu)?

  • SSRS is up and running and I can validate the report server from within Dynamics AX sucessfully. This error is thrown when I try to deploy reports, so I have not been able to deploy therefore run SSRS reports from Dynamics AX.

  • Did you install Reporting Extensions on SSRS box?

    If not - here are the steps-> mafsarkhan.blogspot.com/.../install-dynamics-ax-2009-reporting.html

  • Hi,

    Hope this helps!

    a. Ensure Reporting Extensions is installed in SQL machine, as suggested earlier.   (mafsarkhan.blogspot.sg/.../install-dynamics-ax-2009-reporting.html)

    b. Ensure that in all environments of .net BC and Reporting Extension components, AOS and application file are the same as.

  • I installed Reporting Extensions and then upgraded the code using SP1, this fixed the issue; the link that Adrian and Barry posted opened my eyes to my mistak.

    Now I have SSRS reports running without problems, I did not install Analisys extensions on purpose, though. I now have a report server running just SSRS and DAX Reporting extensions with only reports for the modules I need deployed.

    Thanks so much to Adrian and Barry for replying to my post!

  • HI Ricardo,

    We face the same problems and now it has been resolved.

    Following are the checkpoints:

    1) All the prerequisites has been installed for Report Server. (Windows SDK, Microsoft Visual Studio 2008 Shell  Re-distributable package - Isolated mode, reporting extensions)

    2) Check your Reporting Services Configuration Manager - In the Service Account - you must select the second option "Use Another account and provide the proper credentials". Once done apply the settings

    3) Now run the Report Service Web Service URL's under "Web Service URL tab" and check it's opening correctly. Make sure that the dynamics Folder exists.

    4) If Dynamics Folder doesn't exists. Go to MSDAX 2009 and under Administration >> Setup >> Business Analysis >> Reporting Services  open Reporting Servers now make sure you have the record created and click on "Create" button to create the new Dynamics Folder. You can cross check it by re-visiting the Reports Url in IE. You will find the dynamics folder.

    5) Now go to Report Server and run the Setup Microsoft Dynamics AX 2009 Reports Deployment as administrator. Click on single report and deploy. The reports will deploy and you can verify the same in report manger url.

    Cheers !!

  • I faced the same issue while using report server 2005 but I solved it by correcting the report server url in the report server config file, the problem is that I modified the server name long time ago but didn't change this url, please review the steps from the "Microsoft Dynamics AX 2009 Installation Guide".

    If you are using Reporting Services 2005, use the following procedure to update the configuration file.

    1. Open the rsreportserver.config file. By default, this file is located in \Program Files\Microsoft SQL  Server\ReportingServicesInstance\Reporting Services\ReportServer.

    2. Locate the UrlRoot XML element and update the URL in that element, if necessary.

    <UrlRoot>https://ServerName:PortNumber/reportserver</UrlRoot>

    3. Save your changes and close the file.

    4. Make a backup of the rsreportserver.config file.

  • my advice is to review this installation manual