Question Status

Verified
Tommy Skaue asked a question on 20 Dec 2012 9:11 AM

It seems the Norwegian, Swedish and Finish labels are incomplete for AX2012 R2, and if the system is initialized for a company with any of these languages as primary language, this will create a lot of text and descriptions that contain label references instead of actual texts. Example is Roles and Privileges.

When will the missing languages be shipped? 

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Tommy Skaue responded on 3 Jan 2013 4:49 AM

I found this to be the case after a malfunctioned upgrade to R2 from RTM. A clean install of R2 does not seem to have this problem.

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Tommy Skaue responded on 5 Jan 2013 8:39 AM

I did a new run on this and noticed one difference between an AX2012 R2 new installation compared to one upgraded from AX2012 RTM. In RTM there are several label files (translations of SYS) which are in the model "Foundation Labels II". These are missing in an upgraded AX2012. In a new installation of AX2012 R2, these are all in "Foundation Labels" in SYS.

Why are they lost during an upgrade?

Anyone else experiencing the same?

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Verified Answer
Tommy Skaue responded on 6 Jan 2013 3:54 AM

If you plan to upgrade from AX 2012 RTM to AX 2012 R2 I recommend removing "Foundation Labels II" before running setup on the database (before installing the R2 models). Otherwise you will most likely lose all the languages added in "Foundation Labels II" (ie Norwegian, Swedish, Finnish ++).

This is my experience.

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Pierre Karlsson responded on 7 Feb 2013 7:35 AM

We have this exact same problem. RTM is working fine but the "Fundation Labels II" is "lost" on the R2. What is your recommendation in this case? To  install a clean R2? Is there any way around the problem with the upgraded R2?

Reply
Tommy Skaue responded on 7 Feb 2013 8:06 AM

You need to uninstall the foundation labels II model before you install the foundation labels for R2.  

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
mawa responded on 4 Mar 2013 8:13 AM

Unistall the foundation labels model from upgraded R2 with axutl.

Run R2 setup and select database and configure existing and select foundation labels. Takes a while when setup installs the labels.

That worked for me.

Reply
Verified Answer
Tommy Skaue responded on 6 Jan 2013 3:54 AM

If you plan to upgrade from AX 2012 RTM to AX 2012 R2 I recommend removing "Foundation Labels II" before running setup on the database (before installing the R2 models). Otherwise you will most likely lose all the languages added in "Foundation Labels II" (ie Norwegian, Swedish, Finnish ++).

This is my experience.

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply