Dynamics AX 2012 cubes vs KPIs

This question is not answered

Hello,

 

Got a problem - cannot make AX to display on user dashboard content of KPI/business overview details from OLAP cube.

Cube is generated properly, data is accessible from it (in Excel for example), so I am not assuming cube structure is a problem. In AX, in 'analysis services' details provided are ok - pointing to right server & database - so believe it is also not the problem. Both above seem to be ok, are there any other thing/factor I forgot to set/check?

Problem is that:

1) I can add to dashboard web part labeled 'KPIs' as well as 'business overview'

2) I can add to both above indicators - when pressing 'add indicator' or 'add KPI' (depends on which webpart is used) I can see 'my' cube (can be sure because of I have only project cube available (not all default as per MS - however need to highlight that same problem happen when I am using generic cubes generated directly from AX and not modified after)

3) as soon as indicator / KPI is addedd, I am trying to refresh dashbord having hope will see indicator / KPI, but not; I cannot see any, see only empty webpart (without any indicator / KPI; sorry for language used - it is on polish - but I believe shows clearly what I am writing about)

4) when trying to press 'manage indicators' or 'manage KPIs' (again, depends on webpart used), new window appears with list of indicators / KPIs, but also with error message saying '..at least one identificator contains configuration errors. contact administrator..' and I am lost

Anybody had similar problem? If so, how to make indicators / KPIs work with AX dashboards?

 

regards

t

All Replies
  • Go the same problem. Have you found a solution?

    Ludwig

  • I remember getting this problem quite frequently even before I started developing in Dynamics AX.  Can you see the KPI's in EXCEL? In other words, if you try and view the KPI's in Microsoft Excel (not the web part), can you see them?  That will tell us a lot.  

    Independent, Freelance Consultant and Dynamics Development Instructor

    http://www.instructorbrandon.com

    http://www.youtube.com/user/BrandonAhmad

  • Hi,

    At least I, for my part, can see the KPI perfectly in Excel but not in the webpart. No idea how to fix this issue.

    Hope you can help.

    Ludwig

  • I've got exactly same - KPIs are visible in excel, only AX is not willing to cooperate with them.. and whole cube at all; as I wrote problem is not only with KPIs, but with any webpart which refers to cube

    Ludwig, I hope will have today/tomorrod some advices from MS; if will have it solved will share

  • I have not run into this specific error with Dynamics AX, but I did run into it plenty of times with SharePoint and SQL Server Analysis Services.  

    The symptoms: You have a working data connection that would connect to the cube.  You could tell this because you could connect to the cube in other clients like Excel, and you could connect to the cube in the little popup connector.  

    To make matters more complicated, you know that this feature works out of the box, so this is related to something in your environment..  For example, here I just added the business overview web part (aka status indicator web part in regular sharepoint).  What this tells us is that the feature works out of the box, so we know that this is due to a Enterprise setup/configuration error -- especially if this feature has never worked in your environment. 

    Configuration errors are almost always related to permissions.  More specifically, has the Enterprise portal been configured to work with Analysis Services correctly? I actually need screenshots on what to look for finding this one.  I'm dealing with a client emergency at the moment, but I'm going to try and complete a blog post on it tonight. 

    For now, I need you to go to two logs for me and tell me if you see anything... 

    1. Go to: Program Files --> Microsoft Dynamics AX --> 60 --> Server --> MicrosoftDynamicsAX --> Log.  Open up the "DynamicsAXOLAPComp.log" if it exists on your AOS server. 

    2. On your SQL Server hosting Dynamics AX, go to C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Log.  Open up the log and see if you have anything.  We may have to enable some tracking, so you may not see anything of use. 

    I'll write more throughout the day as I take breaks from work..  will try and have it done before I go to sleep.  Microsoft or you all may find it faster than I get the post out on how to find the error.  Configuration errors are often found pretty fast. 

    Let me also add some helpful links when troubleshooting your portal configuration.  I'm betting that the answer as to what is missing is in these links.  Hopefully, the log files show something to make the process of finding the missing configuration steps easier. 

     

    Check these links.. I'd actually check link 2 before link 1. 

    1. http://technet.microsoft.com/EN-US/library/dd362143.aspx  --> so many times, this is an IIS error.  This link will show you how to fix that and troubleshoot other authentication for Enterprise Portal

    2. http://technet.microsoft.com/en-us/library/dd548356(WS.10).aspx --> the answer is in here.  Your accounts must be configured appropriately.  The fact that you can connect in Excel means that there is nothing wrong with your permissions in the cube.  But have you been appropriately configured for delegation and have the service accounts been setup right?  Possibly not so.. 

    Hope that helps gentlemen.. I actually wrote a lot more than I intended to do so.  Both of you could have two different configuration causes for the same error..  But it's there.  Check the two links carefully.   

     

    Independent, Freelance Consultant and Dynamics Development Instructor

    http://www.instructorbrandon.com

    http://www.youtube.com/user/BrandonAhmad

  • Hello Brandon,

    Thanks for your reply; I am in process of checking links you've provided, however I have small doubts if this is right direction. In my environment I had so far 6 different instances on AX 2012 (AX2012, AX2012pre-R2, AX2012R2), and problem was seen in all of them - what is important, including also images delivered by MS (mean whole setup not done by me, but provided by MS). Considering same issue exists not only in env built by me, but on these deliverd by MS as well (2012, 2012preR2 & 2012R2 I've used had one instance delivered by MS as virtual machine image), reason may be - as I am guessing - little bit more complicated than simple mistake done in case of one setup.

    Additionally, I am attaching printscreen of what I see when trying to add new (in this case) KPI; did not included it before as I thought someone knows the answer already :) but now, to share more details, let me present it (background is in PL again, but I believe it is visible where we are):

    In all cases if I remember well, same error message was shown at this stage; unfortunately I do not feel strong enough to verify script content, but wondering if it may have any impact on how plugin works. Apart from this error, it is possible to add KPI, but later it shows error as described in first post.

    Additionally, checked log files you've mentioned - first one does not exists at all (checked on MS-provided instance, there is all-in-one setup, all components running on one server); in case of second logs, found only msmdsrv.log file, with lot of lines, but only one looks unusual:

    (1/29/2013 1:24:39 PM) Message: Software usage metrics are disabled. (Source: \\?\C:\Program Files\Microsoft SQL Server\MSAS11.MSSQLSERVER\OLAP\Log\msmdsrv.log, Type: 1, Category: 289, Event ID: 0x4121002D)

    All above makes me feel it is some development issue in AX, however I have no clue how to check/verify; today will open case in MS, as soon as (if) will know the answer, will share. Obviously if you (or anyone else) would have any additional suggestions - are more than welcome.

     

    regards

    Tomasz

     

  • Tomasz, this was highly informative.  The script issue is very significant.  Hang with me, and I will make a post on how to:

    A. Enable those logs

    B. Troubleshoot that script issue which may hold some very significant information

    The image I posted above was of the Business Overview WebPart working on my development machine.  However, I did not use the PartnerSource development machine.  I will download it today as soon as Microsoft enables my PartnerSource access.  If I can get a machine where it is not working, that will greatly help.

    Will be in touch with some instructions on how to troubleshoot further, so hang in there.  I'm currently getting a SharePoint 2013 intallation up and prepared for Dynamics functionality, so this is of high interest to me -- even though the versions are different.  

    Independent, Freelance Consultant and Dynamics Development Instructor

    http://www.instructorbrandon.com

    http://www.youtube.com/user/BrandonAhmad

  • Hang in there with me gentlemen.  I've been teaching by day and consulting at night.  I'm going to try and write how to setup troubleshooting logs to find the exact cause of this problem.  

    The reason why this interests me so much is because I saw this problem so frequently in the past.  And I have to admit, when I didn't see any instructions on how to configure the Enterprise Portal for delegation on the Microsoft Website, I wondered if this problem would be seen again or had Microsoft built in the solution within the Dynamics AX setup.  

    Unfortunately, I didn't see the problem on my demo machine.  However, I will try Microsoft's new ax 2012 r2 virtual machine as soon as I get it downloaded.  

    will try very hard to post tomorrow on how to configure the logs to catch the exact cause of this issue.  Please give me just a little longer.  

    Independent, Freelance Consultant and Dynamics Development Instructor

    http://www.instructorbrandon.com

    http://www.youtube.com/user/BrandonAhmad

  • Hi,

    What is the error message in event log?

  • So, I finally got my Dynamics AX machine downloaded and installed from Microsoft, and I think that I know the problem now.  

    First, I checked the Dynamics AX 2012R2 image and the Business Overview Web Part was working fine.  

    My initial assumption was that this was a Kerberos error as it screamed Kerberos.  Then, I decided to double check..  

    I decided to do a real trace of Enterprise Portal -- steps explained here:

    instructorbrandon.com/how-to-troubleshoot-enterprise-portal-performance-in-dynamics-ax-2012r2-with-tracing-a-time-tested-method

    Tip: take it from the instructor.. when you really want to know what is going on, turn on the real tracing feature.  Looking at the trace, if you scroll to the very bottom of that 1500 word post that took me forever to do, you will see that the Dynamics AX image is running in NTLM mode, which works fine until you start trying to access the machine from another computer.  

    Everything worked on the image and I can include screenshots if necessary.  

    My other suspicion for why this was Kerberos is because the Microsoft instructions on the website are incomplete and missing quite a few steps when it comes to Kerberos authentication and setup.  This would cause many people to get an error that would like a hotfix was needed.  

    I could be wrong, as I have not seen your actual environment, but I remember seeing this error so much.  

    Let me know if you still haven't solved this.  I know where you can go for some good instructions on getting the Kerberos setup.  

    Independent, Freelance Consultant and Dynamics Development Instructor

    http://www.instructorbrandon.com

    http://www.youtube.com/user/BrandonAhmad