Question Status

Verified
Freya Tan asked a question on 3 Apr 2013 5:04 PM

Hi Guys,

I'm having an issue importing data with comma using DMF. I am using a CSV file to import it. Though the text with a comma is enclosed in a double qoute, it doesn't process correctly. I already tried to use a pipe delimiter, but it doesn't works also.

Any ideas?

thanks.

Reply
Verified Answer
Tommy Skaue responded on 3 Apr 2013 11:40 PM

I would highly recommend using Tab as Column delimiter, instead of comma. It just makes it easier to copy + paste between text and Excel, plus it is less prune to troubles around commas inside a column value. Sure, quations should handle that, but still

Second thing you need to double check is the codepage being used.

I recommend downloading the free Notepad++ (notepad-plus-plus.org/download) or some other similar text editor. Notepad++ has a menu where you can check the text files current codepage and simply convert it from UTF+8 to ANSI or the other way around (as an example).

You may very well open the file in Notepad (regular) and it looks good, but the import program will not automatically evaluate the codepage being used, and this may result in a failed analyzis of the file during import.

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Suggested Answer
André Arnaud de Calavon responded on 6 Apr 2013 1:05 PM

Did you also check all options in your Source data formats? You can set delimiters for: Row, Column, Multi value and Chart of Accounts (Dimensions). Are these values unique or do some fields have the same setting?

Be sure if you are using the Comma or Pipe that the data itself does not contain these values.

kind regards,

André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

Reply
Verified Answer
Tommy Skaue responded on 3 Apr 2013 11:40 PM

I would highly recommend using Tab as Column delimiter, instead of comma. It just makes it easier to copy + paste between text and Excel, plus it is less prune to troubles around commas inside a column value. Sure, quations should handle that, but still

Second thing you need to double check is the codepage being used.

I recommend downloading the free Notepad++ (notepad-plus-plus.org/download) or some other similar text editor. Notepad++ has a menu where you can check the text files current codepage and simply convert it from UTF+8 to ANSI or the other way around (as an example).

You may very well open the file in Notepad (regular) and it looks good, but the import program will not automatically evaluate the codepage being used, and this may result in a failed analyzis of the file during import.

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Suggested Answer
André Arnaud de Calavon responded on 6 Apr 2013 1:05 PM

Did you also check all options in your Source data formats? You can set delimiters for: Row, Column, Multi value and Chart of Accounts (Dimensions). Are these values unique or do some fields have the same setting?

Be sure if you are using the Comma or Pipe that the data itself does not contain these values.

kind regards,

André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

Reply