AX 2012, latest binaries, OLAP cube vs finansial dimensions

AX 2012, latest binaries, OLAP cube vs finansial dimensions

This question is not answered

Hello,

Maybe somebody has seen similar issue and found solution already; I worked on 2012R2 installed few months ago, prepared OLAP cubes there and SSAS reporting based on these cubes; all things there worked fine.

Now I am trying to do same on latest 2012R2 (lates binaries); prepared dwproj using AX BI tools, processed it, but when opening (excel or VS) I see that:

- financial dimensions defined in AX are available as cube dimension, but

- none of them contains any value defined for them in AX

- also browsing 'FinancialDimensions..' tables in VS (explore data) I do not see any of values mentioned there

As an example - in dimension 'branch' I have few cities defined in AX; in cube I see only dimension 'branch', but not any of defined values.

Is anybody aware what are/may be differencies done in cube/project structure last weeks/month by MS? I believe it is different, but I have no clue why it was changed.

regards

Tomasz

All Replies
  • I don't know for sure it is related, but in R2, every partition gets his own OLAP DB

    do you have multiple partitions incase not, please ignore my 2cents.

  • that's true - however problem do not seem to be related to partitioning, same issue I have on all cubes / all partitions (chcecked all 3 parts I have), so doubt if it is the issue..

  • I don't think that this would resolve but

    has the financial dimension tables backing entity view been filled with data required

    Is any active account structure refereing to the values in the corresponding entity.

    Unless and until this setup is done like atleast one active account structure in chart of accounts these views will not get filled with data.

    Unless these views are filled with data the attribute value table will not have data

    and the same thing applies for the valuecombination tables also.

    The retail cube is separated from the sales cube in 6.2 and additional partition key added in almost all the tables except for language table

  • Thank you for your answer - I believe I've founs root cause, willinvestigate it today. If only I am right, seems that during data migration from DEV to UAT env (problem I am refering to is visible on UAT, after data migration) also some details related to BI were moved; yesterday I've found table where details of sql data connection were stored (right for old env, but not for new one), and seems that each time AX tried to create cubes in new env, project created had data source taken from this table (old, not valid one); today I will try to dig for tables where old partition IDs/company IDs may be stored.

    By the way, if it is the case - then I believe would be good to somehow recommend (?) MS that such data should not be migrated

    regards

    Tomasz