Question Status

Suggested Answer
Steve Murphy asked a question on 20 May 2013 5:14 PM

After making minor modifications to a report, I have begun receiving the following message:

"An item with the same key has already been added."

I have tried several permutations of redeploying the report, restarting the AOS, SSRS, deleting the report and reading, etc.

Nothing has worked. Right now, I am dead in the water with this report. Any suggestions?

Reply
Dick Wenning responded on 21 May 2013 12:58 AM

what is the name of the report or what data sources did you used or changed

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Suggested Answer
Tommy Skaue responded on 21 May 2013 5:19 AM

You've already restarted the AOS, so it can't be this one:

blogs.msdn.com/.../ssrs-error-in-ax2012-an-item-with-the-same-key-has-already-been-added.aspx

Could it be your Query?

blogs.msdn.com/.../getting-message-quot-an-item-with-the-same-key-has-already-been-added-quot-when-creating-an-ssrs-report.aspx

Could you try refresh the Dataset and redeploy the report?

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Suggested Answer
Steve Murphy responded on 21 May 2013 8:17 AM

It was the query. There were columns from two different tables with the same name. I didn't really need one of them, so I removed it from the query. It works now.

Reply
Suggested Answer
Dick Wenning responded on 21 May 2013 8:21 AM

put the option dynamics  to no on the fieldnode of the table.

next remove the fields you don't use.

it will also improve performance :-)

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Suggested Answer
Tommy Skaue responded on 21 May 2013 5:19 AM

You've already restarted the AOS, so it can't be this one:

blogs.msdn.com/.../ssrs-error-in-ax2012-an-item-with-the-same-key-has-already-been-added.aspx

Could it be your Query?

blogs.msdn.com/.../getting-message-quot-an-item-with-the-same-key-has-already-been-added-quot-when-creating-an-ssrs-report.aspx

Could you try refresh the Dataset and redeploy the report?

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Suggested Answer
Steve Murphy responded on 21 May 2013 8:17 AM

It was the query. There were columns from two different tables with the same name. I didn't really need one of them, so I removed it from the query. It works now.

Reply
Suggested Answer
Dick Wenning responded on 21 May 2013 8:21 AM

put the option dynamics  to no on the fieldnode of the table.

next remove the fields you don't use.

it will also improve performance :-)

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply