Maximum buffer size error in Ax 2012 CU3

This question is answered

Hi Folks,

I am facing Maximum Buffer size error in Ax 2012 CU3 while trying to edit a project line item from the project list page. But it allow to edit while I double click the line item from the list page and click the edit button in Project Edit form. This is what I unable to understand the execution of the query which they used in the same form.  In the error msg itself contains and recommends to split the tables in the smaller units. But there are no customized table in that form, all are sys tables and working fine while I am double click which i mentioned earlier. As per some other blogs, they are not suggesting to increase the buffer size due to AOS instability. It's a client environment, they didn't enable debugging. Could any one help on this issue please.

Thanks in advance :-)

Vasanth Arivali

Verified Answer
  • Hi Vasanth,

    The standard AX2012 buffer size is set to 24k. You can increase it. On other implementations this did not result in instability. Then the message dissapears. The standard buffer size in AX2012 R2 is 48k.

    Take also a look at the next thread with the same issue: community.dynamics.com/.../104340.aspx

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • There are perhaps fact boxes open, this will also impact it, minimize them can also help you.

    those have also queries

All Replies
  • Hi Vasanth,

    The standard AX2012 buffer size is set to 24k. You can increase it. On other implementations this did not result in instability. Then the message dissapears. The standard buffer size in AX2012 R2 is 48k.

    Take also a look at the next thread with the same issue: community.dynamics.com/.../104340.aspx

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • Thanks for your valuable reply Andre, I will try this and update you as well :-)

  • Hi André,

    Thanks for your reply again, It is working fine, now I am able to edit the project form. But I am getting the same warning which I got earlier. see the below screen shot. Give me your valuable suggestions

    Thanks in advance,

    Vasanth Arivali

  • go to system administration, Server configurations.

    in the right 2 fast tabs exist, one is batch one and one called performance optimization

    there is setting for Maximum number of tables in joins

  • Hi Dick Wenning,

    Thanks for your valuable reply, How it will affect the performance if I change the count to 30 to 40(currently my issue with 33 and join count is 30). Kindly suggest me.

    Thanks in advance,

    Vasanth Arivali

  • so you have views, queries that have more than 33 joins.  I should analyze these cases and rewrite the queries.

    the warning you get is of warning purpose.  of course you can change it to 100 for example.

    but trust me a form with that kind of queries will slowdown

  • Hi Dick Wenning,

    Thanks for you immediate reply :-)

    I am facing issue in Project Form only. It doesn't contains any customized tables but have customized fields in ProjTable. So there is no added views/tables/queries in that form. That is why I wondered how it exceeds the limit.

    Thanks for your suggestion again.

    Vasanth Arivali

  • There are perhaps fact boxes open, this will also impact it, minimize them can also help you.

    those have also queries