declaring web service.

This question is answered

AX 2009.

Today at the morning, I succeed adding web service as the sample on http://www.microsoft.com/en-us/download/details.aspx?id=4462

I delete and add it several times (due problem 1: The app.config could not be found in the assembly location on the server. This is most likely due to code that is running on the client tier. Please execute code on the server tier)

 and now I cannot even create it (on every environment I have checked):

The remote server returned an error: (403) Forbidden. (problem 2)

What I do is on AOT -> Reference node -> Add service reference. put the URL, and enter a random namespace on rest of fields?

What may be the problem of the above (That just happened, without warnings ...)

How can I check whether this is related to security issue.

Thanks :)

Verified Answer
  • on the AOS server , please past the configuration file in the following path, and replace the appl name with your instance name.

    C:\Program Files\Microsoft Dynamics AX\50\Application\Appl\{appl name}\ServiceReferences\{service ref name}\

All Replies
  • Hi Eitan,

    for problem 2 can you please check if the firewall is turned off on the IIS server.

    Regards,

    Bilal

  • IIS server is currently active.

  • I meant can you please make sure the firewall is turned off to avoid any blocking .

  • OK. I should add : ?wsdl on the end of web service name.

    After some workarround, I understood that app.config is generated and should be on a specific folder (also the <webservice>.dll) - Where should I declare them?

    Thanks :)

  • on the AOS server , please past the configuration file in the following path, and replace the appl name with your instance name.

    C:\Program Files\Microsoft Dynamics AX\50\Application\Appl\{appl name}\ServiceReferences\{service ref name}\