Question Status

Verified
Keane D'Cunha asked a question on 12 Sep 2013 11:10 AM

I've managed to import data into the InventItemPurchSetup, InventItemSalesSetup and InventItemInventSetup tables. However, when I drill into a product's Default Order Settings window, all of the fields are empty and greyed out.

1) Why would the fields be empty?

2) Why would the fields be greyed out? Would fixing #1 solve this issue?

Reply
Verified Answer
Joris de Gruyter responded on 12 Sep 2013 11:29 AM

Check your inventdimid and inventdimidefault fields. For default order settings, the inventdimid field should not contain any dimensions (ie all blank) and the inventdimiddefault field can only have the siteID (although anything else is probably ignored but that's how it should be).

Reply
Verified Answer
Janet Blake responded on 12 Sep 2013 12:33 PM

Keane, when I had this issue, it was because an item did not have a default location. I added a record with an inventDim of AllBlank and it was happy again.

Reply
Keane D'Cunha responded on 13 Sep 2013 12:32 PM

In case anybody else has this problem, the key to fixing my issue was a combination of what Joris and Janet said.

Some of the dimension fields were incorrectly blank (probably a result of a botched export). Once I re-imported the data into the 3 tables with the appropriate data (including corrected inventDimIds with matching dimension information), the Default Order Settings fields were filled and enabled where appropriate.

Reply
Verified Answer
Joris de Gruyter responded on 12 Sep 2013 11:29 AM

Check your inventdimid and inventdimidefault fields. For default order settings, the inventdimid field should not contain any dimensions (ie all blank) and the inventdimiddefault field can only have the siteID (although anything else is probably ignored but that's how it should be).

Reply
Verified Answer
Janet Blake responded on 12 Sep 2013 12:33 PM

Keane, when I had this issue, it was because an item did not have a default location. I added a record with an inventDim of AllBlank and it was happy again.

Reply