Question Status

Unanswered
LearningDynAX asked a question on 25 Mar 2012 9:45 PM

My client is running a batch job which calls a web service to post GL journals. They get this error intermittently (like 2 out of 65,000 lines).

"Cannot create a record in LedgerAccountObject (LedgerAccountObject). 

The SQL database has issued an error.;The log file C:\Program Files\Microsoft Dynamics AX\40\Server\UAT\Log\trcAxaptaError.log for Microsoft Dynamics cannot be opened."

There is a function created during posting to check on something and creates a new GL account if certain condition is met. 

Anyone can shed some light on this issue? 

They are on AX4.0 and SQL Server 2005

 

Reply
Mohammad Atif responded on 28 Mar 2012 4:10 PM

According to the error message either the location C:\Program Files\Microsoft Dynamics AX\40\Server\UAT\Log\ is not accessible or the account is not having sufficient permission.

have you tried changing the default location of the SQL log file and check if you are experiencing the error messages or not.

Thanks,

Mohammad

Reply
ankita agrawal1 responded on 29 Mar 2012 2:25 AM

Hi,

You have to restart the sql server reporting services on the server. For this type services.msc on run on your server and enter then restart the sql server reporting services. This may serve your purpose.

Reply
LearningDynAX responded on 3 Apr 2012 7:15 AM

Hi,

I restarted and and they still get this error sometimes. It happens only once in a while.

Reply
LearningDynAX responded on 3 Apr 2012 7:17 AM

I have also changed the location of the SQL log. The problem still persist. :(

Reply