Analysis Services Configuration ERROR

This question has suggested answer(s)

Hello,

I installed Microsoft Dynamics AX 2012 Feature Pack along with SQL Server 2012. I applied the hotfix and everything went fine except Analysis Services Configuration. It's giving an error!

2012-04-02 18:33:05Z Component installation task completed successfully.
2012-04-02 18:33:05Z === Setting up Components ===
2012-04-02 18:33:05Z Checking the following prerequisites:
2012-04-02 18:33:05Z As the MSI is installed, it will include MSP patch file 'H:\Updates\DynamicsAX2012-KB2606916\MSI\Components64\Components64.msp'.
2012-04-02 18:33:05Z As the MSI is installed, it will include MSP patch file 'H:\Updates\DynamicsAX2012-KB2650968\MSI\Components64\Components64.msp'.
2012-04-02 18:33:05Z Common Property Install Path set to 'C:\Program Files\Microsoft Dynamics AX\60'.
2012-04-02 18:33:05Z Installation Path retrieved from registry. Value: 'C:\Program Files\Microsoft Dynamics AX\60'
2012-04-02 18:33:06Z Running Msiexec.exe with these parms:  /i "H:\MSI\Components64\Components64.msi" /qb! /l*v "C:\Program Files\Microsoft Dynamics AX\60\Setup Logs\2012-04-02 18-30-11\Components64 Log.txt" DIRECTEXECUTE=1 /norestart PATCH="H:\Updates\DynamicsAX2012-KB2606916\MSI\Components64\Components64.msp;H:\Updates\DynamicsAX2012-KB2650968\MSI\Components64\Components64.msp" INSTALLDIR="C:\Program Files\Microsoft Dynamics AX\60" INSTALLDIR32="C:\Program Files (x86)\Microsoft Dynamics AX\60" ADDLOCAL="AnalysisServicesExtensions,EnterprisePortal,NetBusinessConnector,Debugger,EnterprisePortalTools,ReportingServicesExtensions,ReportingTools,ModelManagement,ClientConfig"
2012-04-02 18:33:06Z Running synchronously.
2012-04-02 18:34:12Z Common Property Install Path set to 'C:\Program Files\Microsoft Dynamics AX\60'.
2012-04-02 18:34:12Z Installation Path retrieved from registry. Value: 'C:\Program Files\Microsoft Dynamics AX\60'
2012-04-02 18:34:12Z === Applying Updates to components ====
2012-04-02 18:34:12Z Searching for updates...
2012-04-02 18:34:23Z No applicable updates were found.
2012-04-02 18:34:24Z Checking if Client SDK call to generate WCF configuration is required ...
2012-04-02 18:34:24Z Skipping call to client SDK API. WCF settings already present in the registry.
2012-04-02 18:34:24Z Client SDK Call done.
2012-04-02 18:34:24Z === Setting up Analysis Services configuration ===
2012-04-02 18:34:24Z Creating a record in the BIAnalysisServer table with ServerName = 'WIN-5NPVIAOSMVD\MSSQLServerOLAPService'.
2012-04-02 18:34:25Z Updating OLAP Data Source.
2012-04-02 18:34:25Z Updating the connection string of the SSRS Report Data Source 'DynamicsAXOLAP'.
2012-04-02 18:34:26Z The connection string of the SSRS Report Data Source 'DynamicsAXOLAP' is successfully updated to 'Provider=MSOLAP.4;Integrated Security=SSPI;Persist Security Info=True;Data Source=localhost;Initial Catalog=Dynamics AX'.
2012-04-02 18:34:26Z Adding the Microsoft Dynamics AX .NET Business Connector proxy to the SQL Server Analysis Services Administrator role.
2012-04-02 18:34:27Z An error occurred while adding user REXLAB\Administrator to the SQL Server Analysis Services Administrator role on WIN-5NPVIAOSMVD. The error is Deserialization failed: Requested value 'BusinessIntelligence64' was not found..

2012-04-02 18:34:27Z Registering tracing manifest file "C:\Program Files\Microsoft Dynamics AX\60\Server\Common\TraceProviderCrimson.man".
2012-04-02 18:34:27Z WEvtUtil.exe install-manifest "C:\Users\Administrator\AppData\Local\Temp\tmpB31E.tmp"
2012-04-02 18:34:29Z  **** Warning: Publisher {8e410b1f-eb34-4417-be16-478a22c98916} is installed on
2012-04-02 18:34:29Z  the system. Only new values would be added. If you want to update previous
2012-04-02 18:34:29Z  settings, uninstall the manifest first.
2012-04-02 18:34:29Z  
2012-04-02 18:34:29Z  
2012-04-02 18:34:29Z Tracing manifest file has been registered successfully.
2012-04-02 18:34:29Z ******************************************************************************************************

2012-04-02 18:34:29Z Component installation task stopped due to an error.

2012-04-02 18:34:29Z ******************************************************************************************************
2012-04-02 18:34:30Z S260FinishedInfo


2012-04-02 18:34:35Z  === Setup was canceled or failed. For details see the previous messages in the log.

2012-04-02 18:34:35Z  === Setup logging ended: 4/2/2012 6:34:35 PM ErrorLevel/ExitCode: '1' ===

I then tried another option by installing SQL Server 08 R2. The Analysis Configuration was installed successfully in SQL 08 R2 instance. However, while trying to apply the hotfix to re-try configuration on SQL Server 2012,the hotfix components setup wizard did not see the Analysis services components.

Even when deploying the cube in SQL Server 08 R2 instance, it gave an error :

Please let me know how can I have a successful configuration of Analysis services component in SQL Server 2012.

All Replies
  • Try Re-installing the SQL server analysis services. and Check in User Groups the Specified User is added in that Group

  • Actually, it looks like your deployment to sql 2012 was successful as the database did get created, so the original problem is solved.  What you now have in your last screenshot is a processing error.  The message about arithmetic overflow for a nvarchar field means there is a field length setting in the data source view of the analysis services project which is set too small for your data.  So once that field length setting is updated, it should start working again.

    I can't tell from the output what field overflowed ... but if you reprocess it from sql managment studio you should get a more detailed list of processing errors which should identify to the broken field.

    My guess is it will turn out to be CREDITMAX_NAMECOLUMN in CUSTTABLECUBE.  I'm guessing that because I've seem problems with that one before if there are any customer records with a credit limit set to 10 million or more.  It could also be one of the address fields.  Those defaulted to size 10 at one point, but got changed to size 20 later.  In some upgrade scenarios, that size doesn't get reset in the cube project, which will cause this error.

    To fix it, you have to identify which field is overflowing (which you can get from the processing output in sql managmement studio) and change the field length in the data source view of the analysis services project.

    To change the size limit, open the analysis services project and go to its data source view.

    Find the data source view table that has the overflow.  Copy the value for the QueryDefintion property to notepad so you can see the whole quary string.  Within that query string, find the field definition for the field that overflowed, it will look something like CAST(CREDITMAX AS NVARCHAR(24)) AS CREDITMAX_NAMECOLUMN

    If it was the credit max field, change the size from 24 to 350.  It was an address field update the size to be at least as big as the size of the same field in the sql database.  Typically the address fields are size 20.

    Hope this helps.

  • Hi A.R, did you get any solution for you issue? if yes, kindly share it with me. I got same issue in my server. thanks in advance

  • If the processing fails, it would be easier to identify the actual step that fails by doing a manual processing from within Business Intelligence Development Studio (BIDS).

    Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

  • no, it failed when deploy/install Analysis Services componenet.