reports don't run on all records in current view

This question is not answered

recently we upgraded to UR 13 and now we are experiencing an issue with our reports. I can run the reports for all records or for the selected records but I can't run the reports for all records on all the pages in the current view. I get the same results from a sub grid or from the advanced find. It appears that the filters that I have set in the query are not getting passed to the report when I run the report for all records. is there a setting that we have to change in SQL?

thanks for your help

All Replies
  • Nothing in Update Rollup 13 should have changed this. Can you confirm this worked prior to Update Rollup 13 as well? Is this a custom report? Are you using CRM Online or CRM On Premise?

    Thank you for using Microsoft Dynamics CRM Communities,

    Dynamics CRM Support Blog

    Aaron Richards
    Sr. Support Engineer
    Microsoft Dynamics CRM

     

  • Hi Aaron,

    thanks for your response and questions. Here is some additional information that may be helpful in understanding our environment and issues.

    Roll-ups

    we installed roll up 9 (previously on 7) and ran into issues with an old version of the .NET framework. The version that we were using was not upgradeable. We then installed a newer version of the .NET framework and then we were able to install rollup 13.

    SQL Server Machine includes

    .Net Framework 4 Client Profile --- Version 4.0.30319

    .Net Framework 4 Extended -- Version 4.0.30319

    CRM 2011 Reporting Extensions with update Rollup 13

    CRM Application Server Machine includes

    .Net Framework 4.5 --- version 4.5.50709

    CRM 2011 E-mail Router

    CRM Server 2011 with update Rollup 13

    Report Viewer 2010 SP1 Redistributable ---

    Silverlight --- version 5.1.20125

    When we monitor the SQL server we can see that there is no activity when we try to run the report utilizing the query from the view(IE. all records from all pages in the current view).

    We can take this server off line to repair it but would like to have a well thought out plan prior to trying that.

    Any help that you can provide is appreciated.

    thanks

    Dave  

  • Have you looked at the Report record for this report? Has anything changed in the Report properties (related record types, etc?)

    You can download a copy of the .rdl and open it up in SRS. CRM sticks a parameter in there for reports that alias the views using CRMAF_.

    Can you post what you find in that parameter?

  • I'm not sure if this is what you are looking for but...

    this report has a number of Report Parameters

    One of them is as follows

    Name -- CRM_FilteredProduct

    DataTyp -- String

    Default Value -- <fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="false"><entity name="product"><all-attributes/></entity></fetch>

    Prompt -- CRM_FilteredProduct

    Hidden -- True

    thanks

  • We are continuing to investigate the issues with Reports and have some additional information to share.

    All of our reports worked prior to the Roll-Ups.

    On out of the box reports, i can run them from a view on the entity or from Advanced find, but i can't run them from a sub-grid. For instance, the error message below resulted from running it from a sub-grid.

    Microsoft Dynamics CRM Error Report Contents

    <CrmScriptErrorReport>

     <ReportVersion>1.0</ReportVersion>

     <ScriptErrorDetails>

      <Message>Unable to get property 'text' of undefined or null reference</Message>

      <Line>6</Line>

      <URL>/_common/global.ashx?ver=1447648585</URL>

      <PageURL>/crmreports/viewer/viewer.aspx?action=run&context=fetch&helpID=Activities.rdl&id=%7bd89ac2ff-92a7-de11-bb53-001279d8f644%7d</PageURL>

      <Function>anonymous(contextNode){returncontextNode.text}</Function>

      <CallStack>

       <Function>anonymous(contextNode){returncontextNode.text}</Function>

      </CallStack>

     </ScriptErrorDetails>

     <ClientInformation>

      <BrowserUserAgent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; .NET4.0E)</BrowserUserAgent>

      <BrowserLanguage>en-US</BrowserLanguage>

      <SystemLanguage>en-US</SystemLanguage>

      <UserLanguage>en-US</UserLanguage>

      <ScreenResolution>1280x800</ScreenResolution>

      <ClientName>Web</ClientName>

      <ClientTime>2013-07-12T09:58:42</ClientTime>

     </ClientInformation>

     <ServerInformation>

       <OrgLanguage>1033</OrgLanguage>

       <OrgCulture>1033</OrgCulture>

       <UserLanguage>1033</UserLanguage>

       <UserCulture>1033</UserCulture>

       <OrgID>{7BB4276D-42C2-DE11-BB64-001279D8F644}</OrgID>

       <UserID>{2996AD7F-42C2-DE11-BB64-001279D8F644}</UserID>

       <CRMVersion>5.0.9690.3448</CRMVersion>

     </ServerInformation>

    </CrmScriptErrorReport>

    On Custom reports, we get the same error as above from both a Sub-grid and from advanced find.  

    thanks for any and all comments about where to look next

    dave

  • Hi, maybe this is fixed in the ru14 which came out today?

  • Hi Dave,

    Have you tested this on Update Rollup 14 by chance? Also, have you looked at the SRS logs when trying to view this? C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\LogFiles

    Thank you for using Microsoft Dynamics CRM Communities,

    Dynamics CRM Support Blog

    Aaron Richards
    Sr. Support Engineer
    Microsoft Dynamics CRM

     

  • Hi Aaron,

    we have not tested with Rollup 14. Is there something in that rollup that addresses issues with reporting and/or with advanced find views.

    Also, we have identified an issue that we believe could be causing the issue. It is the AdvancedFindControl.JS file on the CRM Server. It generates XML code and for some reason when it is filtering on the Account, it appears to not include the UIName property of the Account id element.  we are continuing to investigate this also.

    we will take a look at the log files and let you know what we find.

    thanks

  •  I have further documented our issue below and we have identified that code that we believe is causing the issue. Any thoughts/assistance is appreciated.

    When a user tries to run a report from the Advanced Find Control:

     

    And selects the option to include “All Records in the current view”

     

    The report viewer throws a JavaScript Error:

     

    With additional debugging, this is what we found:

    The AdvancedFindControl.js (/_static/advancedfind/advancedfindcontrol.js?ver=1447648585)  file contains the JavaScript that runs the AdvancedFindControl.  It appears that when the user clicks the Run Report option, it builds the FetchXML (all or parts) that gets passed to the report.  A portion of this builds the <condition …> elements.

    The code below shows the line that is causing the issue:

     

    If you look at the xml value on the right side of the screen, the <condition> element does not have a “uiname” attribute, but the code on the left is expecting it.

     

    It appears that the default report filter passed from the Account screen does not have the properly formatted <condition> elements with the “uiname” attribute.  Here is the code that gets the default report filter:

     

    The value of the defaultFilter is:

     "<ReportFilter><ReportEntity paramname=\"AccountFilter\" donotconvert=\"1\" displayname=\"Product Price Items\"><fetch distinct=\"false\" no-lock=\"true\" mapping=\"logical\"><entity name=\"nmipcs_productpriceitem\"><all-attributes /><filter type=\"and\"><condition attribute=\"statecode\" operator=\"eq\" value=\"0\" /><condition attribute=\"nmipcs_focusproduct\" operator=\"in\"><value>0</value><value>1</value></condition><condition attribute=\"nmipcs_account\" operator=\"eq\" value=\"{6219CF94-7911-E211-9D3F-96CDA734CB2C}\" /></filter></entity></fetch></ReportEntity></ReportFilter>"

     

    As you can see, the <condition> element for nmipcs_account does not have a uiname attribute.

     

     

     

     

  • Hi Dave,

    At this time, I would recommend creating a support request to further investigate this issue.

    Thank you for using Microsoft Dynamics CRM Communities,

    Dynamics CRM Support Blog

    Aaron Richards
    Sr. Support Engineer
    Microsoft Dynamics CRM

     

  • We are experiencing this exact same issue and we are also on UR13. Can someone confirm if it is fixed in UR14? Future UR?

  • No its not working in UR14 either. Getting the same error as CRM Dave. Any one have any luck getting this to work?

  • I do get this warning that it won't work, only on a sub-grid --

    (Currently on UR13)