Question Status

Suggested Answer
kterry asked a question on 24 Mar 2014 2:18 PM

In CRM 2013, I have placed a multiple line text field on a form. I have set it to display 4 lines. If I type 20 lines in the field, when I tab out of the field, it will expand the display box to all 20 lines, pushing all fields below it down. In CRM 2011 it used to stay the same size but display a vertical scroll bar. Does anyone know how to keep the display box from expanding.

Reply
Suggested Answer
Satish Tiwari responded on 29 Mar 2014 11:32 AM

Hello KTERRY,

I added a Multiple line of text field on Accounts form and kept no. of rows 4 then save & Publish. Now, I created a new account record and entered the text (approx. 50 words), saved and as expected, I saw scroll bar on the field. After checking the field properties of field added on the form, I found an option "Automatically expand to use available space" under Formatting tab and when I checked this box, I was able to repro the issue.

I will suggest to uncheck the box for  "Automatically expand to use available space" under Formatting tab in field properties, then save & publish and now check if you see a scroll bar in the field or not. Also, test this in existing and new records and let us know the results.

Regards,

Satish Tiwari

Support Engineer

Microsoft Dynamics CRM

Reply
JSpehn responded on 8 May 2014 9:22 AM

I am having the same issue in a CRM 2013 Online Environment. In my example, I am using the Out of the Box Description field on the Lead form. I have this field  to only show 2 lines and the box to "Automatically expand to use available space" is not checked. If I have a lot of text in that field, it will automatically expand, even though that property is not set to expand. It appears that property is being ignored if there really is a larger amounts of text in the field. I have tried it both ways with that option checked and they it behaves the same. In my example, I have close to 2000 characters in that field and all of the text will show on the form. The scrolling bar does appear as the text is being entered. As soon as I tab off of that field, the field expands to show all the text. I hope this gets addressed because it sure takes up a lot of space on my form.

Reply
kterry responded on 8 May 2014 1:01 PM

I opened up a call with Microsoft on this issue over a month ago. They were researching it and last week finally got back to me asking me to submit a business impact statement. I have been to busy to create a lengthy document to fix a bug that is so easy to re-create. I'm surprised more people aren't complaining about it. I did submit today a brief impact statement. I'll post any results I get.

Reply
Ashish Khanna responded on 28 May 2014 8:00 PM

Did you get a reply about this? I am facing the exact same issue??

Reply
kterry responded on 29 May 2014 6:34 AM

No, I haven't. It seems to have disappeared into a black hole with Microsoft.

Reply
Arbind Tiwari responded on 23 Aug 2014 9:34 AM

Hi Satish,

I am using multiline text and have given line displayable 3. I need scroll bar if entered text exceeds then 3 line. I have not checked auto expand checkbox as I wanted scroll bar, but still I am not getting vertical scroll bar. Can you please suggest how to get scrollbar on that control?

Reply
Elisabeth K responded on 28 Aug 2014 7:41 PM

Unfortunately unchecking the "Automatically expand to use available space" does not solve this issue. I don't see the fix available in the Rollup 3 either. Has anyone had any progress on this issue?

Reply
Srijana Pokharel responded on 17 Sep 2014 3:23 PM

I am having the same issue. Do we have any update on this?

Reply
Suggested Answer
Satish Tiwari responded on 29 Mar 2014 11:32 AM

Hello KTERRY,

I added a Multiple line of text field on Accounts form and kept no. of rows 4 then save & Publish. Now, I created a new account record and entered the text (approx. 50 words), saved and as expected, I saw scroll bar on the field. After checking the field properties of field added on the form, I found an option "Automatically expand to use available space" under Formatting tab and when I checked this box, I was able to repro the issue.

I will suggest to uncheck the box for  "Automatically expand to use available space" under Formatting tab in field properties, then save & publish and now check if you see a scroll bar in the field or not. Also, test this in existing and new records and let us know the results.

Regards,

Satish Tiwari

Support Engineer

Microsoft Dynamics CRM

Reply