Question Status

Suggested Answer
Damon (nomad) asked a question on 27 Feb 2015 10:35 AM

Hello Everyone:

I need some help connect CRM to Outlook so we can send emails within CRM.

Note I do have Outlook connect to CRM so when I'm in Outlook I can connect with CRM.

Here are my sys settings.

My active Mailbox:

My Mailbox Settings:

When I try to set the Incoming Emails and Outgoing Email to Microsoft Exchange I get this error

Error Code:

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Delivery method for mailbox associated with a queue cannot be outlook client.Detail:
<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
  <ErrorCode>-2147098096</ErrorCode>
  <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
  <Message>Delivery method for mailbox associated with a queue cannot be outlook client.</Message>
  <Timestamp>2015-02-27T16:21:31.5953614Z</Timestamp>
  <InnerFault i:nil="true" />
  <TraceText i:nil="true" />
</OrganizationServiceFault>

Any advice or help would be great.

Thanks

_damon

Thanks

_damon

Reply
Suggested Answer
Mamatha Swamy responded on 27 Feb 2015 10:59 AM

Check if any queue has a mailbox configured... Queues cannot have Outlook as email delivery method

Reply
Damon (nomad) responded on 27 Feb 2015 11:01 AM

How do I find this info.

Thanks

_damon

Reply
Suggested Answer
Aileen Gusni responded on 27 Feb 2015 11:07 AM

Damon,

You need to set the Outlook method to the specific user, not the Queue.

Do not go to your Mailbox by going to Queue View, instead just go to the user.

And double click the Mailbox from there, example:

 

Then will open new pop up windows for setting.

Just change the Incoming and Outgoing profiles to Outlook based on what you want.

 

But, remember once you set this, the user can only send email through the Outlook or through CRM then will send after they connect using Outlook, not like you use Email Router can send the email directly and immediately at that time.

 

Hope this helps.

Thank you.

Reply
Suggested Answer
Mamatha Swamy responded on 27 Feb 2015 11:21 AM

In the image you posted for Mailbox

1. set the Regarding as User (form screen shot... couldn't read the selection to see if it is a user)

2. Change Incoming/Outgoing email to 'CRM for outlook'

Test the configuration..

Reply
Damon (nomad) responded on 27 Feb 2015 1:55 PM

OK I made the changes and activated  the mailbox, but now I get this:

It's being like this for a good hour

Any help would be great.

Thanks

_damon

Reply
Mamatha Swamy responded on 27 Feb 2015 3:15 PM

Can you check for any related alerts on the mailbox?

Reply
Damon (nomad) responded on 27 Feb 2015 6:20 PM

Hi Mamatha:

No... not alerts still the same

Thanks

_damon

Reply
Aileen Gusni responded on 27 Feb 2015 8:13 PM

Damon,

Try directly to install the connector to the respective users.

Usually MS for Outlook not too difficult to setting, try to login and send email.

Usually the alert error test in progress like that only if you want to test server side sync.

Thank you.

Reply
Suggested Answer
Mamatha Swamy responded on 27 Feb 2015 10:59 AM

Check if any queue has a mailbox configured... Queues cannot have Outlook as email delivery method

Reply
Suggested Answer
Aileen Gusni responded on 27 Feb 2015 11:07 AM

Damon,

You need to set the Outlook method to the specific user, not the Queue.

Do not go to your Mailbox by going to Queue View, instead just go to the user.

And double click the Mailbox from there, example:

 

Then will open new pop up windows for setting.

Just change the Incoming and Outgoing profiles to Outlook based on what you want.

 

But, remember once you set this, the user can only send email through the Outlook or through CRM then will send after they connect using Outlook, not like you use Email Router can send the email directly and immediately at that time.

 

Hope this helps.

Thank you.

Reply
Suggested Answer
Mamatha Swamy responded on 27 Feb 2015 11:21 AM

In the image you posted for Mailbox

1. set the Regarding as User (form screen shot... couldn't read the selection to see if it is a user)

2. Change Incoming/Outgoing email to 'CRM for outlook'

Test the configuration..

Reply