Question Status

Suggested Answer
Wael El Zahr asked a question on 24 Mar 2015 4:10 AM

Hello,

I'm trying to import a solution deployed on a customer's server. I'm getting the following error:
"The entity relationship role of the referencing entity is required when creating a new one-to-many entity relationship new_entitlement_iss_delegations."

Noting that "iss_delegation" is a custom entity. There is no relationship between it and entitlement entity.

Anyone knows what might be the problem? 

Reply
Bas van de Sande responded on 24 Mar 2015 4:22 AM

Looks like you have to do some troubleshooting:

Did you check your relationship in your solution?

You can view your relationships on per entity through Settings -> Customizations -> Entities.

Did you try to import your solution on a different organization?

Does your solution import without the specific relationship?

Reply
Wael El Zahr responded on 24 Mar 2015 4:26 AM

Thank you for your quick reply.

I did look at my relationships but found nothing related to entitlement. I did not even add it to my entities.

I didn't try to import it to another organization since I need it in a specific one.

And I couldn't find the relationship to try importing without it

Reply
Bas van de Sande responded on 24 Mar 2015 4:30 AM

what publisher name are you using in your solution, "new" ? It might be that you have a conflicting publisher name.

Reply
Wael El Zahr responded on 24 Mar 2015 4:33 AM

I'm using "iss" as publisher name.

I'm not the only person working on a solution so I'll wait and see other people working on the solution know where the "new_entitlemenet" came from.

Thanks for your time buddy

Reply
Bas van de Sande responded on 24 Mar 2015 8:19 AM

you're welcome

Reply
Suggested Answer
Vighnesh GVR responded on 24 Mar 2015 8:39 AM

There could be many reasons for the solution error and based on the error message you said it is with the Relationships.

Based on my previous experience somebody may have created/updated a relationship in the solution and it is showing a mismatch, please check for that particular entity and the prefixes for solution, entity and publisher.

If possible try to find more information by downloading the LogFile which is generated while importing the solution.

One thumb rule while importing is all the components should match in both source and target environment and if there are any third party tools added, check for them as well and make sure there is no mismatch between the components, even a slight change in field datatype will cause an error while importing.

Reply
Suggested Answer
Hakim Fubara responded on 24 Mar 2015 12:16 PM

Hi Wael,

I have heard of a few people with a similar issue.

I think you will need to raise a support issue with Microsoft to get this resolved.

Reply
Suggested Answer
Vighnesh GVR responded on 24 Mar 2015 8:39 AM

There could be many reasons for the solution error and based on the error message you said it is with the Relationships.

Based on my previous experience somebody may have created/updated a relationship in the solution and it is showing a mismatch, please check for that particular entity and the prefixes for solution, entity and publisher.

If possible try to find more information by downloading the LogFile which is generated while importing the solution.

One thumb rule while importing is all the components should match in both source and target environment and if there are any third party tools added, check for them as well and make sure there is no mismatch between the components, even a slight change in field datatype will cause an error while importing.

Reply
Suggested Answer
Hakim Fubara responded on 24 Mar 2015 12:16 PM

Hi Wael,

I have heard of a few people with a similar issue.

I think you will need to raise a support issue with Microsoft to get this resolved.

Reply