Question Status

Suggested Answer
Andrew73 asked a question on 27 Mar 2015 11:47 AM

Hi,

We are on CRM 2015 and IFD, when I set up Outlook client and try to connect to internal url, Configuration Wizard prompt me for CRM credentials. Is it ok? I assume since url is internal I will be authenticated without prompting for credentials, like in a browser.

Thanks

 

Reply
RJC-SK_Admin responded on 27 Mar 2015 2:39 PM

I do believe that credentials when you log in through the browser are stored in the browser, where when you log in using the outlook client the credentials are stored in Windows Credential Manager. From my tests I cannot populate the Web Credentials of Windows Credential Manager using CRM in the browser.

Reply
Andrew73 responded on 27 Mar 2015 5:39 PM

Thank you for a suggestion,

I believe in case of browser credentials are not stored in browser, but browser gets a ticket from ADFS.

Fro some reason Configuration Manager wants credential to be storesdin Windows Credential manager. I hope there is a way not to  store them on client and not refresh them every time AD password is changed.

Thanks.

Reply
Suggested Answer
Bruno Lucas responded on 29 Mar 2015 8:10 PM

Try this:

Resolve prompt for credentials

1.Add the add website address for the AD FS server (for example, https://sts1.contoso.com) to the Trusted Intranet Zone in Internet Explorer.

2.Turn off Extended Protection. On the server running IIS for the Microsoft Dynamics CRM website:

Turn off extended protection on the Microsoft Dynamics CRM website.

a. Open IIS.

b. Select the Microsoft Dynamics CRM website.

c. Under IIS, double-click Authentication.

d. Right-click Windows Authentication, and then click Advanced Settings.

e. Set Extended Protection to Off.

https://technet.microsoft.com/en-us/library/jj203437.aspx

Could the client machine be running a VPN or connecting to some other network that could cause some DNS confusion?

Bruno Lucas, Senior CRM Consultant

DynamicDay CRM Blog 

Please mark my post as "Verified" If it helped to solve your problem 

Reply
Suggested Answer
Bruno Lucas responded on 29 Mar 2015 8:10 PM

Try this:

Resolve prompt for credentials

1.Add the add website address for the AD FS server (for example, https://sts1.contoso.com) to the Trusted Intranet Zone in Internet Explorer.

2.Turn off Extended Protection. On the server running IIS for the Microsoft Dynamics CRM website:

Turn off extended protection on the Microsoft Dynamics CRM website.

a. Open IIS.

b. Select the Microsoft Dynamics CRM website.

c. Under IIS, double-click Authentication.

d. Right-click Windows Authentication, and then click Advanced Settings.

e. Set Extended Protection to Off.

https://technet.microsoft.com/en-us/library/jj203437.aspx

Could the client machine be running a VPN or connecting to some other network that could cause some DNS confusion?

Bruno Lucas, Senior CRM Consultant

DynamicDay CRM Blog 

Please mark my post as "Verified" If it helped to solve your problem 

Reply