Question Status

Unanswered
Jamie P asked a question on 5 Aug 2010 9:03 AM

Has anyone used the new feature to update records in the CRM through import yet?  I'm having a difficult time getting it to work right.

If I export to excel from advanced find, change a field, and save as a .csv file, excel adds another column on save.  Not a big deal until you try to import it - it fails saying that data map doens't contain a column that is in the .csv file.  But it doesn't tell you which data map it's using so you can fix it, you can't even pick another map it just says automatic in the field.

If I delete this extra column in the csv file, then I can pick my data map, but CRM does not give me the option to Add to exsisting records so it creates duplicates.

 Any help would be great.

-JP

Reply
Mike S responded on 6 Aug 2010 3:26 PM

Hi Jamie,

I'm guessing that the column you're referring to is the GUID/Key field for the records you have exported.  This is typically the last column in the Excel file.

 If this is the case, cut/paste this column (the column name is usually "(entityid)") into column A and change the column heading to the entity in which you're working.  For instance, if the heading is "(leadid)" change this to "Lead".

 Go to the end of the file and delete the last 5-10 columns as the import will usually recognize these as blanks.

 Now when you upload the file, the import wizard should identify the entity your working with, automap all fields, and the "enrich" option should be available.

 Try this out and let us know.

Reply
Leon Tribe responded on 7 Aug 2010 2:04 AM

As an aside, this is not so much a new feature as the artifact of a feature that was removed from version 4 at the last minute. Its use is unsupported and if you have foreign characters in your data they will get corrupted.

Leon Tribe

Want to hear me talk about all things CRM? Check out my blog

http://leontribe.blogspot.com/ 
or hear me tweet @leontribe

Reply
Jamie P responded on 9 Aug 2010 6:10 AM

I thought the ability to append data was new to Roll Up 11?

Reply
Jamie P responded on 9 Aug 2010 6:16 AM

Thanks for the reply.

The entityid is already the first column and named Competitor (the entity I'm trying to update).  I tried clearing this heading and retyping competitor, but on import the system saw it as new data and didn't let me append.

 Without changing the ID column I tried deleting the last 10 or so columns and rows, but it still failed on import.

 I'm saving the excel file as a .csv file - is there another type of file that would work better?  Any other thoughts?

-JP

Reply
Leon Tribe responded on 9 Aug 2010 7:00 AM

The ability to do it has been there since it was released. I can't see anything in the notes for RU11. The inherent problem is csv is not unicode compliant and therefore the process cna corrupt data. You can import using unicode txt tab delimited files. I'm not sure that will trigger the enrichment though.

Leon Tribe

Want to hear me talk about all things CRM? Check out my blog

http://leontribe.blogspot.com/ 
or hear me tweet @leontribe

Reply
Rejane Ribeiro responded on 16 Jun 2011 6:48 AM

Hello people,

We're having difficulty with update/enriching but only with the LEAD entity.

It doesn't work with any kind of attribute, even the most simple. We get error messages about IsSystem and CRM try to map a system attribute.(probebly the GUID)

Does anybody know why it happens only the LEAD? With Contacts, for example, no problem to import.

Did you have any experience like this before?

We have rollup 17 updated!

Thanks!

Reply
Rejane Ribeiro responded on 16 Jun 2011 12:27 PM

We found out what was the problem.

Our Lead entity had it's exbition name change.

After we changed to the original name, it worked.

Tks!

Reply