Question Status

Unanswered
lana feldman asked a question on 28 Feb 2012 12:39 PM

Hello.

We have Upgraded CRM 4 to 2011. On the CRM 4.0 we used to have Anonymous Authentication of the CRM website Disabled. On the New version this setting prevents Email Router from sending outgoing emails.

Configuration Details: CRM 2011 and Email Router are installed on the same box.in The EM manager settings: Email Server type: SMTP; Authentication  is Windows; Access Credentials: Local System. The User that we test with setup with incoming Forward Mailbox; Outgoing - Email Router.

If Anonymous Authentication of the CRM website switched to Enabled on the CRM website - emails flow through. But we'd like to keep it Disabled.

Does Anonymous Authentication required for the Email Router? Are any of this settings incorrect?

Thank you.

Reply
Gus Gonzalez responded on 28 Feb 2012 12:41 PM

Lana,

I don't think it is required...you can also follow these steps to configure your email rotuer as well:

www.zero2ten.com/.../Configuring-CRM-Email-Router-as-a-Virtual-SMTP-Server.aspx

Good Luck!

Reply
lana feldman responded on 1 Mar 2012 8:43 AM

This article is about creating an SMTP server on CRM server itself, this is something we don’t want to do

Reply
lana feldman responded on 1 Mar 2012 9:06 AM

Another piece of information:

as soon as I disable Anonymous Authentication on CRM Website, E-mail Router Conf. Manager is unable to Load Data on "Users, Ques, and Forward Mailboxes" tab. And Enabling Anonymous fixes that.

I suspect this is related to our problem.

Looking for more ideas. Thanks a lot.

Reply
Mohammad Atif responded on 12 Mar 2012 1:08 PM

Hi Lana,

Anonymous Authentication is enabled in CRM 2011 by default. So please do not desable it.

Thanks,

Mohammd

Reply
lana feldman responded on 12 Mar 2012 1:56 PM

Hi Mohammad,

Thanks for the answer.

I left Anonymous enabled on the Website level and disabled it only for ISV nod. Is that ok?

The problem is that if it's enabled than on my custom asp page Request.ServerVariables("AUTH_USER") returns blank, but I need to know who is looking at the page. Is there any other way to do this.?

Thanks.

Reply
Mohammad Atif responded on 12 Mar 2012 2:09 PM

Hi Lana,

Please let it be enabled for CRM website which is by default settings and see the behavior.

Thanks,

Mohammad

Reply