Question Status

Verified
Richard Wheeler asked a question on 2 Apr 2012 6:51 AM
I have created a test image which is an active directory server. I have successfully installed the Application Service and the Process Service. However, it always fails when creating the Dynamics GP Connector. I am logged in as the domain admin. This is the error I am getting. Microsoft.Dynamics.Performance.Reporting.Common.ReportingPermissionException: You don't have permission to perform this operation. at Microsoft.Dynamics.Performance.Reporting.Security.Service.SecureServiceBase.SecureExecuteInternal[TResult](Func`1 hasPermission, Func`1 executor) at Microsoft.Dynamics.Performance.Reporting.Common.Service.ServiceBase.BaseExecute[TResult](Func`1 executor) Component: Microsoft.Dynamics.Performance.Reporting.DataAccess.Server.CompanyService User: MyDomain\Administrator What is causing this and how do I get around this?

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Ian Grieve responded on 2 Apr 2012 9:20 AM

Have you made sure the domain part of the username is in capitals?

e.g. MYDOMAIN\Administrator


Author of azurecurve|Ramblings of a Dynamics GP Consultant
Senior Consultant at Perfect Image Ltd

Perfect Image/ Dynamics GP
Tel: +44 (0) 843 289 2656
Equinox House, Cobalt 3.2, Silver Fox Lane, Silverlink, North Tyneside, NE27 0QJ, United Kingdom

Reply
Verified Answer
Ryan Sandness responded on 2 Apr 2012 10:27 AM

Hi Richard,

The user running the configuration console needs to be an Administrator in Management Reporter in order to import companies. Most likely you are logged in as the domain administrator, but either ugpraded a MR database where this user was not a MR user, or you created a new database and selected some other user as the MR Administrator. Please log onto this machine as the user you selected as the MR Administrator, and then you will be able to import companies.

Thanks

Ryan

Reply
Verified Answer
Ryan Sandness responded on 2 Apr 2012 10:27 AM

Hi Richard,

The user running the configuration console needs to be an Administrator in Management Reporter in order to import companies. Most likely you are logged in as the domain administrator, but either ugpraded a MR database where this user was not a MR user, or you created a new database and selected some other user as the MR Administrator. Please log onto this machine as the user you selected as the MR Administrator, and then you will be able to import companies.

Thanks

Ryan

Reply