Question Status

Unanswered
Carl Holzhauer asked a question on 22 May 2013 12:54 PM

While trying to open the HITB reset tool, I get a

"There was a problem creating the tables, please contact support"

Google turns up nothing

(No, I haven't contacted support)

Reply
Richard Wheeler responded on 22 May 2013 1:22 PM

Are you logged in as 'sa' when you initialize this tool?

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
AdamH responded on 22 May 2013 1:24 PM

Hi Carl,

It sounds to me like you have a security issue with the system trying to create the new tables and/or stored procedures.

I would check that the user you are running it under has appropriate rights to the GP database.

Hope this helps,

Adam

Reply
Carl Holzhauer responded on 23 May 2013 5:14 AM

I ran this as SA

Reply
Richard Wheeler responded on 23 May 2013 6:29 AM

Was there a 'More Info' button to at least give us a clue as to what the problem is? I do not know if the scripts that run can create tables that already exist. We need to find out what the real problem is. Can you try running SQL Profiler while you attempt to initialize the HITB Reset tool?

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Carl Holzhauer responded on 23 May 2013 6:36 AM

Nope, that was it.  I'll run profiler now and see what I can see

Reply
Carl Holzhauer responded on 23 May 2013 6:41 AM

Here's a link to the profiler output

http://mars.sscorp.com/profiler.trc

(do a right click, save link as)

Reply
Richard Wheeler responded on 23 May 2013 6:56 AM

What version of SQL are you using?

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Carl Holzhauer responded on 23 May 2013 6:58 AM

2012

Reply
Richard Wheeler responded on 23 May 2013 7:24 AM

Unfortunately nothing unusual is in this trace file. It is using the DYNGRP. I would start by checking the mapping of the DYNGRP. It needs db_owner and public on the DYNAMICS and company databases.

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
AdamH responded on 23 May 2013 7:26 AM

Hi Carl,

You might also check the windows event log to see if it gives you additional error details.

Adam

Reply
Carl Holzhauer responded on 23 May 2013 7:35 AM

Richard - DYNGRP didn't have DB_Owner, but even after changing that, I have the same error

Adam - Unfortunately there's nothing in the logs

Reply
Richard Wheeler responded on 23 May 2013 8:52 AM

Do you have multiple companies? Can you trying initializing this tool in the Fabrikam company? I am running out of ideas. You may need to open a support call with MS.

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Carl Holzhauer responded on 23 May 2013 9:53 AM

Yes, multiple companies.  I hadn't tried Fabrikam yet, I'll try that now.

Reply
AdamH responded on 23 May 2013 9:58 AM

Hi Carl,

For the Windows event log, did you try on both the server and client?

Thanks,

Adam

Reply