Question Status

Verified
Zaza asked a question on 5 Jul 2013 11:58 AM

Hi, after installing the Web Client, I get an unexpected error when trying to Sign In.  

This is what I see in the event log when trying to sign in.. Have someone seen this error before?

An error occurred while creating a session: '

Date: 05/07/2013 2:37:46 PM

SessionId: dufaisab_2013-7-5_14-37-46-492_HR-FIN-V

ProcessId: 0

ProcessUsername: cstmcorp\dufaisab

TenantName: GPWebApp

ApplicationDirectory: C:\Program Files (x86)\Microsoft Dynamics\GP2013\

DexInitializationFile: C:\Program Files (x86)\Microsoft Dynamics\GP2013\Data\Dex.ini

SetFile: C:\Program Files (x86)\Microsoft Dynamics\GP2013\Dynamics.set

Exception Details: System.ComponentModel.Win32Exception (0x80004005): The directory name is invalid

  at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)

  at Microsoft.Dynamics.GP.Web.Services.Session.SessionProcess.StartableSessionProcess.TryToStartProcess()

  at Microsoft.Dynamics.GP.Web.Services.Session.SessionProcess.StartableSessionProcess.Start()

  at Microsoft.Dynamics.GP.Web.Services.Session.Service.SessionCreator.CreateSession(SessionCreationContext creationContext, Uri runtimeServiceBaseAddress, SessionUserInfo sessionUserInfo)

'.

Reply
Verified Answer
Zaza responded on 9 Jul 2013 12:00 PM

Its working...  ;-)

Reply
Steve Kubis responded on 6 Jul 2013 9:15 PM

What path did you choose to install the GP web client? Did you use the default location in the GP Web Client installer, or did you pick a different path? When a new session is created, some data is written to a session folder that is located inside of the GP Web client installation location you specified. If this path is too long (greater than 255 characters, if I recall correctly) then the files can't be created. If that's the case, then you need to install the web client into a location with a shorter path.

Reply
Zaza responded on 8 Jul 2013 10:02 AM

Hi,

Thank you very much for your reply.. I'm running the GP2013 web client installation from the SP1 package and the installation does not ask for the installation path so it must be installing in the default location.  I did the Single machine installation..  

I've just removed and reinstall the WebClient and IIS is pointing to C:\program files\Microsoft Dynamics\GP Web Client\GPWeb.   Got the same error... ;-(

Reply
Zaza responded on 8 Jul 2013 11:57 AM

Hi again,

When I go in my webmanagementconsole and I click on 'Session Management' and then click on the 'configure' button, it gives me this message:  The required URL to the Session Central Service was not valid or being reconfigured.  Then it lists my url which is --> hr-fin-v.ad.technomuses.ca/SessionCentralService

If I try to acces that URL directly, it loads a page about Windows© Communication Foundation service.

The only think I notice is that that URL uses ad.technomuses.ca while to access GP, the URL I enter is https://hr-fin-v/GP/Views/LogOn.aspx. (ad.technomuses.ca is our AD domain name)

Reply
Steve Kubis responded on 8 Jul 2013 7:44 PM

When you log in to the Dynamics GP web client site, do you get a security certificate error? You need to use the fully-qualified domain name for the machine in every place that it's needed, such as when you supply the URL to access the web client.

That means you should be using hr-fin-v.ad.technomuses.ca/GP

to access the web client. That should also be the full name that you saw when you chose the security certificate for the Session service.

If the names aren't consistent, you'll see security certificate errors, and the login won't be successful.

Reply
Zaza responded on 9 Jul 2013 7:20 AM

I tried with URL hr-fin-v.ad.technomuses.ca/GP..   I no longer get a certificate error but I still get the same error message recorded on my server:  the directory name is invalid.. (see below).  

PS.. The 2 GP services

An error occurred while creating a session: '

Date: 09/07/2013 10:10:53 AM

SessionId: dufaisab_2013-7-9_10-10-53-185_HR-FIN-V

ProcessId: 0

ProcessUsername: cstmcorp\dufaisab

TenantName: GPWebApp

ApplicationDirectory: C:\Program Files (x86)\Microsoft Dynamics\GP2013\

DexInitializationFile: C:\Program Files (x86)\Microsoft Dynamics\GP2013\Data\Dex.ini

SetFile: C:\Program Files (x86)\Microsoft Dynamics\GP2013\Dynamics.set

Exception Details: System.ComponentModel.Win32Exception (0x80004005): The directory name is invalid

......

and I'm still getting the following error in the webmanagementconsole when I click on configure:  The required URL to the Session Central Service was not valid.  The URL is --> hr-fin-v.ad.technomuses.ca/SessionCentralService

This error does not generate anything on the server that I could find...  

Many thanks for your help..

Reply
Zaza responded on 9 Jul 2013 7:22 AM

PS.. The 2 GP servcies are up and running..  

Reply
Steve Kubis responded on 9 Jul 2013 7:41 AM

The only thing I see that's different on your installation is the machine name. Personally, I've never used any special characters in the machine name. Your machine name contains dashes. I don't know whether that's a problem...it's just a difference I can see.

There are a couple of things you can try to see if you can get more information about the issue. First, show the hidden folders on the system. When you log in, you should see folders in the C:\ProgramData\Microsoft Dynamics\GPSessions\Data\ folder. This is where temporary data is written for each session, and where the web client may be having issues writing to a directory.

The second thing to do is to turn on logging for the web client. Page 78 of the Web Client Installation and Administration Guide (for SP1) tells you how to do that. You'll need to update the TenantConfiguration.xml file to turn on logging. The logging can be extensive, but may give you an idea of what's actually happening when the error occurs.

Reply
Zaza responded on 9 Jul 2013 11:38 AM

Hi again,

Arggghhh... I think I've found my problem... I do not have the GP Desktop client installed (with the web client runtime) on my IIS server.  I should have looked with both eyes open as it is clearly mentionned in the documentation (d'oh)...   I'll let you know of the outcome.

Many thanks for your help troubleshooting.

Reply
Verified Answer
Zaza responded on 9 Jul 2013 12:00 PM

Its working...  ;-)

Reply