Tax Import Quirk

This question has suggested answer(s)

I have two odd situations occurring when I import Tax Details using the Table Import utility in Dynamics GP (I'm using that because I see no way to import Tax Details or Tax Schedules via the Integration Manager).

1. Everything imports perfectly with the exception of the GL Account - it does not import (no errors found when running Check Links).

2. I can pull up an individual Tax Detail record and manually enter the GL Account, either by inputting it directly or search for it, but the system will not let me save it (even though it fills in the Account Description, I can use the Account Details link to go to Maintenance, etc.).  It gives me the following error message:

"Some information entered is outside the range of possible values for Microsoft Dynamics GP. The invalid record will not be saved."

This seems very odd, since the system is obviously recognizing the GL Account, as indicated above.

Any ideas?

Todd

All Replies
  • Todd,
    I will need some more information to try and help you find a resolution to your issues. Could you please provide me with what version of GP you are using? What Database you are using and also what Operating System you are running.

    Best Regards,
    Nick Hoban

  • Nick:

    Thanks for the response; I appreciate it.

    Version of GP is 10.0 SP3.

    Database is MS SQL Server 2005

    OS is Windows Server 2008

    Thanks, again.

    Todd

  • Todd,
    This is what I have found out around your question. Please try these suggestions to see if they resolve your issue.

    1) Create a new Tax Detail by going to Tools, Setup, Company, Tax Detail. Ask him to enter all information in this window that is required plus the GL Account number he wants this to go to.
    2) Pull up a Tax Detail that was brought in with Table Import and select a GL Account that he wants this to go to.

    In both cases, we would like a DEXSQL.log of this process. I have included a link to KB 850996 which explains how to create a DexSQL.log.

    How to create a Dexsql.log file for Microsoft Dynamics GP and Great Plains
    https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?scid=kb;en-us;850996

    Ask Todd to turn this on then log in to GP. After opening the Tax Detail (for number 1 above), delete the DEXSQL.log. Once this is done, this is when Todd should enter a new record. Once all the information is entered, he should click Save. If this saves fine, copy the DEXSQL.log to another location and rename this to “Option 1 Success DEXSQL.log”.

    If it is unsuccessful, leave the error onscreen and copy the log, renaming it to “Option 1 Fail DEXSQL.log”.

    Then, for number 2, Todd should pull up an existing Tax Detail ID that was brought in through Table Import. At this point, delete the DEXSQL.log. Attempt to add a GL Account and when the error appears, copy the DEXSQL.log and rename it to “Option 2 Fail DEXSQL.log”.

    Once these are created, we will need to have them attached to this case for review and we will determine where to go from here.

    Please let me know if these steps have helped resolve your issue.

    Best Regards,
    Nick Hoban

  • Nick:

    First of all, this is still Todd Bowlsby - I have changed my Windows Live ID, so had to create a new profile on here.

    Secondly, thanks for following up on this so diligently.  Unfortunately, at this point, it's a moot issue as the client's IT consultant accidentally blew away my entire install and implementation - 25 hours worth of work gone bye, bye!  The ironic thing was that when he did it he was implemeting a backup system.  Ha!

    Anyway, if I see this situation again, I'll definitely gather the information requested.

    Again, thanks so much for your help.

    Todd Bowlsby

  • Has anyone found an answer to this? I am having exactly the same problem - after importing a tax detail ID, I cannot go back and manually enter an account number in Dynamics GP without getting "Some information is outside the range of possible values for Microsoft Dynamics GP..."

  • OK, I think I've found the answer. Set TX00201.TaxPostToAcct = 1.

  • I would try to use the account index rather than the account number.   The table import is a data dump.   It will not do an data validation or trigger any stored procedures.   It is worth a try.  

    Dan Liebl, CMA CPIM | Senior Consultant | OTT,Inc | DLiebl@OTT-inc.com

  • Thanks for the suggestion, but I was not using table import - I was using a SQL script and I did use the account index.  Setting field TaxPostToAcct = 1 solved my problem.