Question Status

Suggested Answer
Jim Ferolie asked a question on 10 Feb 2014 12:59 PM

When you create a 'Related Report Link' in the 'Output and Distribution Tab' in report designer, it is created, but clicking the link does not bring up the MR Web viewer and encapsulated report. The MR Web client is installed. There is no error message. Any help would be greatly appreciated. Thanks in advance!

Reply
Santosh Gangadhara responded on 10 Feb 2014 10:54 PM

Hi,

This error can be caused by using invalid characters in the report Output name (ex: period at the end) in the Report Definition in Report Designer. SharePoint has specific file name requirements that need to be adhered to. You can view these requirements support.microsoft.com/.../EN-US

Remove the invalid characters from the report's Output name per the SharePoint requirements.

Hope this helps.

Regards,

SantoshG

Reply
Jim Ferolie responded on 11 Feb 2014 10:06 AM

Santosh , Thanks for the quick reply. The naming convention for the reports are not using invalid characters. I was hoping that this was the issue.

Reply
Stella D responded on 5 Mar 2014 2:58 PM

Did you guys ever resolve this? we are having the same issue with our client...

Reply
Suggested Answer
Jim Ferolie responded on 7 Mar 2014 12:51 PM

Yes - there are two settings in each SharePoint library where you publish the links that must be set. If you follow the instructions correctly for SQL Server Reporting Services, you probably set up the initial library correctly. When you add more pages and libraries you must change the same two settings for each Document Library you create:

1. Under Library Tools > Library > Library Settings > Advanced Settings changed "Allow Management of Content Types" from No to Yes

2. Under Content Types in your Document Library Settings page clicked on "Add from Existing Content Types" and added the "Link to Document" content type.

Reply
Suggested Answer
Jim Ferolie responded on 7 Mar 2014 12:51 PM

Yes - there are two settings in each SharePoint library where you publish the links that must be set. If you follow the instructions correctly for SQL Server Reporting Services, you probably set up the initial library correctly. When you add more pages and libraries you must change the same two settings for each Document Library you create:

1. Under Library Tools > Library > Library Settings > Advanced Settings changed "Allow Management of Content Types" from No to Yes

2. Under Content Types in your Document Library Settings page clicked on "Add from Existing Content Types" and added the "Link to Document" content type.

Reply