Question Status

Verified
Víctor José Morcillo Díaz asked a question on 21 Jul 2014 3:58 AM

Hi there.

I've created a new company inside the same database as other companies. As this company needs to have the same contacts I looked for a solution in google. Many people say that they solve this using "DataPercompany" = no, but other ones say that it's better synchronize tables using programming with CHANGECOMPANY method.

What do you think about?

Reply
Suggested Answer
Mohana Yadav responded on 21 Jul 2014 4:03 AM

If you have to set "DataPercompany" = no for contact table then make sure that you have to set DataPercompany to all related tables which are used in Contacts.

ex: There is a field Territory Code in Contact table which has TableRelation to Territory table.

If you don't set DataperCompany to No for Territory table then you wont see data when lookup on Territory Code.

similarly, you can get errors while doing some process.

Reply
Víctor José Morcillo Díaz responded on 21 Jul 2014 5:07 AM

Thank you. In those cases I though to copy records cause it's not data that usually change like "Salutation Code" or "Post Code"...or "Territory Code".

My main problem is to know if it's neccesary to change "DataPerCompany" to "No" in Vendor, Customer, etc and other related tables to Contact table, because there are other companies in database which have the same "No. serie" field and they would overlap with each others.

Other question is about what will happen when we migrate NAV 5.1 to NAV 2013 R2?. Will this be (sharing tables) a problem?

Cheers.

Reply
Verified Answer
Miguel Llorca responded on 21 Jul 2014 6:38 AM

Hi Victor! Avoid using "datapercomany" = no, use this method as your last option. You'll solve your problem today, but you'll have tons of new problems in the future (upgrades, etc.). (En resumen...yo no lo haría ni de coña :-))

Good luck!

Miguel LLorca Gómez

Reply
Mohit Khandelwal responded on 21 Jul 2014 5:12 PM

You can share in your new company by using make some code for insert or modify  contact in new company when you perform activity in old company.

Do not use DataPerCompany option.

Reply
Verified Answer
Miguel Llorca responded on 21 Jul 2014 6:38 AM

Hi Victor! Avoid using "datapercomany" = no, use this method as your last option. You'll solve your problem today, but you'll have tons of new problems in the future (upgrades, etc.). (En resumen...yo no lo haría ni de coña :-))

Good luck!

Miguel LLorca Gómez

Reply
Suggested Answer
Mohana Yadav responded on 21 Jul 2014 4:03 AM

If you have to set "DataPercompany" = no for contact table then make sure that you have to set DataPercompany to all related tables which are used in Contacts.

ex: There is a field Territory Code in Contact table which has TableRelation to Territory table.

If you don't set DataperCompany to No for Territory table then you wont see data when lookup on Territory Code.

similarly, you can get errors while doing some process.

Reply