Question Status

MNH asked a question on 28 Aug 2013 5:34 PM

Hello- I am running into an issue releasing a Voucher and Adjustment Entry batch. When I go to release the batch I receive an error:

System Message 6124: Process started: Wed Aug 28 04:42 P.M.

Module: 'AP'

Batch: '027028'

Processing: Module: 'AP' , Batch: '027028'

System Message 12008: Batch number  '027028'  has already been released by

                     another user.

System Message 6125: Process ended: Wed Aug 28 04:42 P.M.

The batch showes status "Partially Released", handling "No Action" and both fields are greyed out. I have to go into Release AP batches to attempt to release the batch.

Any thoughts here on what to do?

Elaine Rettig responded on 29 Aug 2013 9:04 AM


I am guessing that you will find that the batch.rlsed = 1 (true) but the status  is  S meaning that the data is inconsistent.  Normally an S status batch has rlsed = 0.

See if there are any GLtrans for this batch.  You will have to do a query to find this because an unreleased batch won't show up in GL>Journal transactions.

Select status, rlsed,* from batch where batnr = '027028' and module = 'ap'

Select rlsed, posted,* from gltran where  batnr = '027028' and module = 'ap'

If the gltrans exist and are released, then update the batch.rlsed to 1 (true) and status to U.

If the gltrans.rlsed = 0, then update batch.rlsed to 0

MNH responded on 29 Aug 2013 4:39 PM

Thanks for the help. I updated the batch flag to 0 after seeing no glran records for this batch and it released ok.

Luanne Pang responded on 7 Oct 2013 11:04 PM

I had the same problem and your suggestion worked! THank you

Mark Kosakowski responded on 5 Oct 2015 2:43 PM

I'm running into a very similar issue where the AP batch shows partially released in the user interface but the status = S and rlsed = 0 in the batch table.

Mark Kosakowski responded on 5 Oct 2015 2:44 PM

I forgot to add that there is no data in the GL.