Question Status

Unanswered
Angela Schatz asked a question on 7 May 2013 7:52 AM

Hi,

We are just in the process of migrating to SL 2011 and in the process of testing.  Some of our users are encountering issues with no menus when logging in either on a local install or Citrix.  When you look at the users group permissions everything has migrated over correctly.    Has anyone encountered this?  Your assistance is greatly appreciated.  

Thanks

Reply
Mark Cronin responded on 7 May 2013 3:10 PM

Are those users in the Everyone group?

Reply
Cory Winkler responded on 10 May 2013 1:59 PM

Hi Angela,

Please browse to the following folder:

C:\Users\[username]\AppData\Roaming\Microsoft Dynamics SL\MenuCache

and delete all of the files that are located within the folder. Once deleted have the user log into SL, their menus should rebuild themselves.

If the above does not work please try updating them through SQL Management Studio by doing the following:

---------------- Copy into SQL Management Studio ------------------------------------------

select CacheMenu, UserId, UserName, * from userrec where rectype = 'u'

update userrec set CacheMenu = 'Number from 1st script + 1 (make sure to select the correct user)' where UserId = 'input user id' and UserName = 'input user name'

--If only 1 record was updated please run the following:

Commit

--If more than 1 record was updated please run the following and let me know:

Rollback

--------------------- End of SQL script ------------------------------------------------

Make sure to add 1 to the Cachemenu returned in the first script.

Thank you,

Cory Winkler

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

 

Reply
Cory Winkler responded on 11 May 2013 6:32 AM

Hi Angela,

In reviewing the above code I see that I forgot to place something in front of the update statement please run the following before the update statement:

Begin Tran

Thank you,

Cory Winkler

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

 

Reply
cmoody responded on 13 May 2013 8:02 AM

have you tried updating under user maintenance the windows user name?

Reply