Business Analyzer: Cannot create a connection to data source 'DynamicsSLSystem'

Business Analyzer: Cannot create a connection to data source 'DynamicsSLSystem'

This question is answered

Hi there - I'm running into an issue when trying to view SL2011 FP1 Business Analyser reports.

As i try open the report via http://server/Reports, (i can navigate to the reports fine):

An error has occurred during report processing. (rsProcessingAborted)

Cannot create a connection to data source 'DynamicsSLSystem'. (rsErrorOpeningConnection)

Login failed for user 'E8F575915A2E4897A517779C0DD7CE'.

Does SL need to be running in Windows Authentication mode to run business analyzer?

Verified Answer
  • Hi JAMES,

    Provide the proper User access , Proceed with the below mentioned steps.

    1. Focus the BA Report in mentioned link, Click the Drop Down box and click (Edit in report Builder) option

    2. Drill down the Data sources through the report builder, then Right click DB and Click Data source properties, Refresh the connection.

                                                                        (or)

    Create a new connection, Click Connection Embedded Radio button and Select connection type as Microsoft SQL server then click build button, select server name, select the Log on the server as (Windows Authentication (or) SQL Authentication) and Test the Connection.

    3. Save and Close the BA charts in Report Builder.

    Thanks,

    Ajit Kannan


    Microsoft Dynamics® SL 2011 Installation and Configuration

  • Hi james,

    Enable Internet Explorer to run components signed with Authenticode.

       1. Open Internet Explorer

       2. Click the menu Tools

       3. Click Internet options

       4. Click Security tab

       5. Select Trusted sites zone

       6. Click Custom Level

       7. Check the item Run components signed with Authenticode

       8. Select Enable

       9. Click OK to apply

    Thanks,

    Ajit Kannan


    Microsoft Dynamics® SL 2011 Installation and Configuration

All Replies
  • Hi JAMES,

    Provide the proper User access , Proceed with the below mentioned steps.

    1. Focus the BA Report in mentioned link, Click the Drop Down box and click (Edit in report Builder) option

    2. Drill down the Data sources through the report builder, then Right click DB and Click Data source properties, Refresh the connection.

                                                                        (or)

    Create a new connection, Click Connection Embedded Radio button and Select connection type as Microsoft SQL server then click build button, select server name, select the Log on the server as (Windows Authentication (or) SQL Authentication) and Test the Connection.

    3. Save and Close the BA charts in Report Builder.

    Thanks,

    Ajit Kannan


    Microsoft Dynamics® SL 2011 Installation and Configuration

  • Thanks for the response Ajit...

    I tried to open report builder and get an error: "Cannot Start Application - Cannot continue, the application is improperly formatted. Contact the application vendor for assistance"

    I googled this error and checked a few things, which didnt help :(

    any idea on this one?

    thanks again

    James

  • Hi james,

    Enable Internet Explorer to run components signed with Authenticode.

       1. Open Internet Explorer

       2. Click the menu Tools

       3. Click Internet options

       4. Click Security tab

       5. Select Trusted sites zone

       6. Click Custom Level

       7. Check the item Run components signed with Authenticode

       8. Select Enable

       9. Click OK to apply

    Thanks,

    Ajit Kannan


    Microsoft Dynamics® SL 2011 Installation and Configuration

  • Thanks for the response Ajit

    I have already got that in place though. - the site http://server/ is already a trusted site, with the above mentioned setting already enabled...

    any other ideas?

  • Hi James,

    Back up the Custom  Reports if you contain , then reconfigure through Microsoft  dynamics SL Report server configuration console.

    Thanks,

    Ajit Kannan


    Microsoft Dynamics® SL 2011 Installation and Configuration

  • Hi James

    Regarding Report Builder launch issue, you have to create role assignments that grant access to Report Builder

    >Start Report Manager.

    >Click Site Settings.

    >Click Security.

    >If a role assignment already exists for the user or group for which you want to configure Report Builder access, click Edit.

    >Otherwise, click New Role Assignment. In Group or user, enter a Windows domain user or group account in this format: <domain>\<account>. If you are using forms authentication or custom security, specify the user or group account in the format that is correct for your deployment.

    >Select System User, and then click OK.

    >Click Home.

    >Click the Folder Settings tab.

    >Click the Security tab.

    >If a role assignment already exists for the user or group for which you want to configure Report Builder access, click Edit.

    >Otherwise, click New Role Assignment. In Group or user, enter a Windows domain user or group account in this format: <domain>\<account>. If you are using forms authentication or custom security, specify the user or group account in the format that is correct for your deployment.

    >Select Report Builder, and then click Apply.

    >Repeat to create or modify role assignments for additional users or groups.

    For further information refer the below links

    technet.microsoft.com/.../ms365173.aspx

    blog.summitcloud.com/.../enable-ssrs-report-builder-to-launch-from-a-sharepoint-site-when-using-forms-authentication

    Thanks

    Santhosh D

  • Hi guys - thanks for the help

    Ajit - it turned out to be the IE settings/trusted sites :(

    Thanks!