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TechTalk 
Series

• Session 1 - Unified Admin Experience (YouTube Link)

• Session 2 – Unified Development Experience
• Session 3 – Unified Dev ALM

https://www.youtube.com/watch?v=24RS5YgXnEc&feature=youtu.be


Agenda

Objectives | Why UDE
Unified Developer Environment | Provisioning 
Developer workstation | Install VS, Dev Tools
Write, deploy, debug, and test X++ code
Write, deploy, and debug Dataverse Plugins
SQL Access | F&O, Dataverse
Trace Parser | F&O
Resources
Q&A
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What problems is UDE solving?
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Power Apps Power Automate Power BIPower Virtual Agents Power Pages

FinanceSupply Chain 
Management

Dataverse

Visual Studio Power Platform CLI ALM Developer tools



Faster innovation 
using common tools 
for unified Dynamics 
solution 
development

Better business 
outcomes with 
turnkey integrations 
and common 
capabilities to activate 
data

Workloads are 
managed more easily 
with a single simplified 
administration 
experience

Unified Development Experience Benefits

Increased developer 
productivity 

Faster dev 
environment setup

Faster troubleshooting 
of production issues 

Secure / more 
compliant 
environments

Reduction of TCO



Classified as Microsoft Confidential

Available Now!Unified Development Experience 

• “Stripped down” Tier2 SaaS environment

• Single AOS for Interactive & Batch loads

• Same ALM and ELM capabilities

• Local Visual Studio with connection(s) to cloud 
environment(s)

• Incremental X++ package updates into existing environment

• Remote Debugging directly from local Visual Studio

• Remote Unit Test execution directly from local Visual Studio

• SQL Access from Visual Studio

AOS Azure SQL Dataverse AOS Azure SQL Dataverse AOS Azure SQL Dataverse

Visual Studio



Classified as Microsoft Confidential

Unified Developer 
Environment | 
Provisioning

Saurabh



Classified as Microsoft Confidential

Available Now!Provision new Unified Developer environment (via PowerShell) 

Visit M365 Admin Center for Role and License
Visit Capacity report in Power Platform Admin Center

• Open PowerShell in Admin mode
• Construct JSON

• DevToolsEnabled = True (Mark False if creating Non-Developer (Sandbox) environment)
• DemoDataEnabled = False (Mark True if need Demo data)

• Templates = D365_FinOps_Finance / D365_FinOps_SCM / D365_FinOps_ProjOps
• DomainName = For unique Environment Name (DisplayName don’t guarantee env URL)
• LocationName = Run “Get-AdminPowerAppEnvironmentLocations” to identify location names such as 

“unitedstates”
• Always deploy on latest Service & Quality Update

Tutorial: Provision a new environment with an ERP-based template
New-AdminPowerAppEnvironment (Microsoft.PowerApps.Administration.PowerShell)

https://learn.microsoft.com/en-us/power-platform/admin/unified-experience/tutorial-deploy-new-environment-with-erp-template?tabs=PowerShell#create-an-environment-1
https://learn.microsoft.com/en-us/powershell/module/microsoft.powerapps.administration.powershell/new-adminpowerappenvironment?view=pa-ps-latest
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Demo – Create Unified Developer Environment via 
Powershell
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Developer 
workstation | Install 
Dev Tools
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Available Now!Developer workstation - Prerequisites

• Windows 10 or 11 instance (laptop, desktop, vm, cloud box, etc.) with minimum 4 cores and 
16GB RAM. SSD preferred. Good network bandwidth.

• 16+ GB of free space on the local system drive

• Visual Studio 2022
• .NET desktop development
• Modeling SDK
• DGML editor
• Microsoft Reporting Services Projects

• SQL Server Management Studio (SSMS)

Visual Studio requirements for X++ - Finance & Operations | Dynamics 365

https://learn.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/dev-tools/developer-tools-vs2017#required-visual-studio-components
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Available Now!Install / Setup Development tools

Install and configure development tools (preview) - Power Platform

• Ensure access to UDE in sys admin role 

• Go to VS > Manage Extensions> Online> Search ‘Power Platform Tools for VS 2022’

• Test connection to SQLServer LocalDB

• Go to VS > Tools > Download Dynamics 365 FinOps assets 
• If using MFA or a guest user account also ensure skip Discovery is enabled. 
• Go to VS > Tools> Options > Power Platform Tools and ensure Auto setup is enabled.
• Download Client assets from VS>Tools menu
• Review progress in VS output pane

https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-install-config-tools
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Demo – Install / Setup Development tools
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Demo – Write, Deploy, and Debug in X++



Write, deploy, and 
debug X++ code
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Available Now!Write, Deploy, and Debug X++

• Create a model 
• Create a project with X++ objects (classes, tables etc.)
• Build the Project

• Deploy Model to Online Environment
• DB Sync to Online Environment if needed
• Unit Testing to Online Environment

• Include Models/Packages to debug
• Set Breakpoints

Write, deploy, and debug X++ code - Power Platform

https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-debug
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Demo – Write, Deploy, and Debug in X++
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Available Now!Create, Update, Deploy, Delete and Debug in Dataverse

• Create a project with project templates in Visual Studio or with PAC CLI
• Write or update your plugin code in C# using Visual Studio
• Build the project

• Deploy Plugin with Visual studio or Plugin Registration Tool
• Browse/Create/update/delete Plugin Steps

• Add Plugin Assembly and Steps to your solution in maker portal

• Start profiling directly in Visual Studio or in Plugin Registration Tool
• Set Breakpoints and attach in Visual Studio
• Start execution in Visual Studio or in Plugin Registration Tool

Tutorial: Debug a plug-in (Microsoft Dataverse)

https://learn.microsoft.com/en-us/power-apps/developer/data-platform/tutorial-debug-plug-in?tabs=prt
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Demo – Write, Deploy, and Debug for Dataverse
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SQL Access
Trace Parser
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Available Now!SQL Access – F&O

• Visual Studio > Tools > SQL 
Credentials for Dynamics 365 
FinOps

• Provide a reason, choose 
between Reader and Writer 
roles

• Request Access

• Provide Details
• Connect

SQL Access for Dataverse - Use SQL to query data (Microsoft Dataverse) - Power Apps

https://learn.microsoft.com/en-us/power-apps/developer/data-platform/dataverse-sql-query
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Available Now!SQL Access – Dataverse

• For Dataverse, direct SQL 
access is not possible even 
in Dev/Sandbox 
environments

• Using the TDS Endpoint, 
you can use SSMS to read 
Dataverse tables, but with 
many limitations

SQL Access for Dataverse - Use SQL to query data (Microsoft Dataverse) - Power Apps

https://learn.microsoft.com/en-us/power-apps/developer/data-platform/dataverse-sql-query
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Available Now!Trace Parser

Capture a trace - Finance & Operations | Dynamics 365
Diagnose issues and analyze performance by using Trace parser - Finance & Operations

Find & Install 
“TraceParser.msi”in the 
following location: 
C:\Users\<User>\AppData\Lo
cal\Microsoft\Dynamics365\
<ApplicationVersion>

Register Database

https://learn.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/perf-test/trace-trace-tutorial
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Available Now!F&O Copilots Extension

Tutorial - Create client plugins for Copilot in finance and operations apps - Finance & Operations

• Unified Dev Env (UDE) 
• 10.0.40 or later
• Copilot in finance and 

operations apps

Contextual Record
• Navigation Context
• Page Context
• User Context
• Current Record
Client Actions
• Add X++ class extends 

to 
SysCopilotChatAction

AI Plugins for F&O 
business logic

https://learn.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/copilot/tutorial-create-client-plugins?source=recommendations
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Resources
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Admin Experience Advantages - CHE vs UDE

Factors Customer Hosted Environment 
(CHE)

Unified Development Environment 
(UDE)

Azure subscription Needs Azure subscription Not Required

Security & compliance Customer must manage Microsoft would manage

Azure quota management Customer must manage Not Required

New environment setup Takes 8+ hours Less than 1 hour

Service & Quality updates Customer must manage Microsoft would manage
With Microsoft Power Platform / 
Dataverse

Customer must manually integrate with 
CHE Fully integrated environment

Service and quality updates rollback Not supported for failed updates Supported for failed updates

Copy production data to troubleshoot Multi-step and multi-day process Less than 4 hours for most data sizes
Deploy changes / cyustomizations to 
cloud Takes a few hours Takes a few minutes

Customer Managed Keys enabled Not possible Available
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Developer Experience Advantages - CHE vs UDE

Factors Customer Hosted 
Environment (CHE)

Unified Development 
Environment (UDE)

Extending Copilot capabilities with F&O Not supported Supported

Add-ins support for development Not supported Supported

Bring your own device Not supported Supported

CI: Run X++ Unit Tests in Az DevOps pipelines Not supported Supported

CD: Deploy to UDE via Az DevOps pipelines Not supported Supported

Work with multiple F&O runtime versions Not supported Supported

Faster debugging with new protocol Not supported Supported

Out of box connectivity to both Dataverse and F&O Not supported Supported
Author, deploy, debug and test X++ and Dataverse artifacts to both 
Dataverse and F&O from Visual Studio Not supported Supported
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FAQs

Can multiple developers share a single UDE?
• Yes, for non simultaneous testing or debugging
• Yes, if doing bug fixes occasionally using source version control 
• Potentially, if developers are working on independent modules using source version 

control
• No, when development is happening on the same or highly dependent modules

Can a single developer workstation be used for multiple UDEs?
• Yes, a dev workstation can be used to connect to multiple UDEs
• Yes, can switch using multiple VS configuration

Frequently asked questions (preview) - Power Platform | Microsoft Learn

https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-faq


Post GA Scope!Roadmap - Upcoming features

Persona Feature Purpose
Admin Support in sovereign 

clouds
Support in Mooncake, GCC, GCC High clouds 

Admin Restore Ability to back point in time with-in same environment or restore from 
another environment

Admin Delete and Recover Ability to recover a deleted environment

Admin Transaction-less copy 
via UI

Ability to select copy options from PPAC Copy UI

Admin Microsoft managed 
updates

Ability for Microsoft to push updates to UDE environments

Dev SQL JIT custom 
reader/writer roles

Tweak the roles to grant additional permissions for development scenarios

Dev Reduce Xref DB size Compress the cross-reference database for reduced size

Dev Visual studio Add-ins Add-ins that needs to access the database directly will get addressed using 
developer's SQL Jit credentials
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Resources 

Viva Engage : Dynamics 365 and Power Platform Preview Programs : Private Preview: Online Development

Unified admin experience for finance and operations apps (preview) - Power Platform | Microsoft Learn

Unified developer experience for finance and operations apps (preview) - Power Platform | Microsoft Learn

One Dynamics One Platform – TechTalk Series

What is Power Platform Tools for Visual Studio - Power Platform | Microsoft Learn

Tutorial: Copy a Lifecycle Services environment to a unified environment (preview) - Power Platform

Tutorial - Create client plugins for Copilot in finance and operations apps - Finance & Operations

Install and configure development tools (preview) - Power Platform

Frequently asked questions (preview) - Power Platform | Microsoft Learn

https://www.yammer.com/dynamicsaxfeedbackprograms/#/threads/inGroup?type=in_group&feedId=126835908608
https://learn.microsoft.com/en-us/power-platform/admin/unified-experience/finance-operations-apps-overview
https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-dev-overview
https://community.dynamics.com/blogs/post/?postid=0bf71ad7-6f83-449e-8bb5-51672532f962
https://learn.microsoft.com/en-us/power-platform/developer/devtools-vs
https://learn.microsoft.com/en-us/power-platform/admin/unified-experience/tutorial-copy-lifecycle-services-environment-unified-environment?tabs=PPAC
https://learn.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/copilot/tutorial-create-client-plugins?source=recommendations
https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-install-config-tools
https://learn.microsoft.com/en-us/power-platform/developer/unified-experience/finance-operations-faq
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Thank you!   
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