AX 2009 AIF Tool and Wizard: Update Document: Service says "Class does not exist"

Question Status

Michael_Land asked a question on 12 Feb 2013 6:20 AM


I have done some exercise with AX 2009 AIF training material.

There is a chapter 2 where a Document is created using AIFWizard. It' started creating Query and then the document with Wizard.

The problem is that Service class doesn't work at all. It has all read, findByKeys, find etc. methods and project containing whole project compiles without errors.

When trying to define Data Policys in Endpoint Action Policies containig this service ( as Action Id throws error: Class 0 does not exist.

I also tried to use AIF Tool "Update Document" to this Service but same error comes. Purpose of this exercise is to read an XML file's data into system. I should do this kind of feature into my own project.  AX 2009 AIF material contains lot's of errors and also some phases are missing.

Does anyone have had this issue before and remember why it comes? Like to get this feature working.

Best Regards





Shashi Sadasivan responded on 18 Feb 2013 5:40 PM

Havent seen such an error ... does this link help?

It talks about fixing the issue as the aifActions are already generated for that class, but something in the background must have changed the ID's