Ledger Allocation Rule Error Message

Question Status

Mike Meyer asked a question on 3 Apr 2013 2:23 PM

I am coming across an error message "No Records Found for Allocation Source" when using the Ledger Allocation Rule.  We have setup the rule, we are using fixed percentage, we have a source account (general ledger account and dimension) and a destination for the source (a few accounts and percentages listed).  We have followed the steps in the AX 2009 training manual but we still receive this message.  Would anyone have any guidance on how to allocate a balance in a general ledger account using fixed percentages or has anyone seen this error?


Sachin Ahuja responded on 5 Apr 2013 9:17 AM

Did you check for the transactions in Source Account from where you want to allocate the amount.

Mike Meyer responded on 5 Apr 2013 4:21 PM

I did post some transactions into the general ledger account and dimensions chosen so there is a balance in the source account.  I am not sure if anyone else might have a suggestion on how to get the balance to split out.


Mike Meyer responded on 8 Apr 2013 12:09 PM

Hi...I have still not found a solution for this.  I have set up my allocation method as a fixed percentage.  Other details include:

Data Source = Ledger

Mathematical Operation = Multiply

Amount = 100.00

I have set the journal settings "Journal Name" field to a specific allocation Journal name and made sure the journal type is allocation.  

On the offset tab, I have set my offset account to "Source" and the Offset dimension to "Source".

When I click on the source button, I have my account 980230 and my dimesion department 998.

When I click on the destination button, I have the accounts and dimensions that I wish to split this to.  They add up to 100%

I have even tried setting up a brand new GL account to attempt to see if it might work with no luck however.  


Fjorela Dardha responded on 23 May 2017 4:54 AM

Hi Mike,

I am facing a similar situation.

Could you please give me any useful hint?

Many thanks,


Ludwig Reinhard responded on 23 May 2017 5:35 AM

Hi Fjorela,

Would it be possible that you create a new thread and add some supporting details - possibly screen-prints - to your question/issue?

Many thanks and best regards,


Fjorela Dardha responded on 29 May 2017 9:40 AM

Hi Ludwig,

the issue was the same as reported at the beginning of this thread ("No Records Found for Allocation Source").

We managed to solve it by specifying all the financial dimensions with 'source criteria' equal to *.

By specifying only the account, the system would select only the source transactions without financial dimensions.

Best regards,


Kaled Alloud responded on 12 Jun 2017 7:04 AM

Can you please verify the answer? so that the question is now 'Answered'?

this would help the community find appropriate results.