AX 2012 - Event ID 117 how do you trouble shoot this

This question is not answered

Looking at the application event log on the AOS server I am see a lot of  event 117 error messages with the following text:

Object Server 01:  The database reported (session 1 (-AOS-)): [Microsoft][SQL Server Native Client 10.0][SQL Server]Warning: Null value is eliminated by an

aggregate or other SET operation.. The SQL statement was: "UPDATE SYSCACHEFLUSH SET CLEARDATA=?,RECVERSION=?,MODIFIEDDATETIME=? WHERE ((RECID=?) AND (RECVERSION=?))"

How do I troubleshoot this?  I've tried looking on the SQL server but don't see any errors.

All Replies
  • Did  you get answer for your problem? I have the same issue. One of the AOS stopped and even after restarting it is not taking any clients.

    Thanks

  • No I have not solved this yet.

  • Do you have any web services active, a webshop/storefront maybe? How many AOS's do you run?

  • We have 4 AOS servers running.  We have some AIF services running.

  • We run 10 AOS instances on 10 Servers.

    In the evenlog on some of the servers do we encounter the same error under EventID 117. A restart of the affected AOS seems to help for a period of time untill it appears again.

    In the eventlog we do encounter another error under the same EventID 117, this is a nasty one since the application gives an error that it cannot connect tot the SQL database, this is not tackled untill so far.

    Object Server 01:  

      [Microsoft][SQL Server Native Client 10.0]Communication link failure

      session 2 (-AOS-)

  • Hi all,

    Take a look at the next link: blogs.msdn.com/.../event-117-changed-language-setting-to-us-english.aspx

    It gives an explanation of the cause. A solution was provided for AX2009 but I wonder if this was only focussed on the SysLastValue problems as referred in the article.

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • AndrĂ©, event 117 on its own can have any of a million reasons.

    I'm investigating a similar issue here and it appears to be originating from the SysCacheFlush table. That is my main reason for leaning towards AOS synchronization issues. This would also explain why restarting the AOS solves the issue (temporarily)

    The reason I asked about AIF is that in my situation the first error always seems to come from a webshop user. Can't say if this is the cause or just the first effect though.

    Are we all running multiple AOS's on VM's? And if so, has anyone compared the cluster/resource pool logs of their VM server against the times that these 117 events pop up?