TFS sync error + MSB4018: The "GenerateRdlTask" task failed unexpectedly.

Question Status

SomuAx2012 asked a question on 14 Feb 2014 9:07 AM

MSB4018: The "GenerateRdlTask" task failed unexpectedly.
Microsoft.VisualStudio.Modeling.ModelingException: Cannot save \SSRS Reports\Reports\CustAccountStatementExt because it is checked-in. Check out the node and redo your operation.

Receiving the above error for couple of other reports on Force synchronizing with TFS.

Steps followed to receive this error. Our TFS is linked to a model in CUS layer

1. Take SQL Backup from prod

2. Restore the backup in DEV environment

3. Delete the TFS workspaces from Visual studio>solution explorer on DEV 

4. Start AOS

5. open AX> Setup TFS parameters

6. Start Force Sync

Tried deleting and readding the reports to TFS

Tried on couple of other dev machines

Tried deleting all the CUS layer changes(deleted the model), Compile, database sync, CIL and TFS sync

Please help

Klaas Deforche responded on 14 Feb 2014 10:24 AM


Do you have visual studio projects for these ssrs reports in the AOT under \Visual Studio Projects\Dynamics AX Model Projects?

I think I saw this error before. I believe that simply compiling the report will also trigger the same error as it tries to modify the project that matches the report. It does that when compiling a report (of for example when synchronizing with tfs, which will also compile the report). This won't happen with a full compile for some reason. It also doesn't happen in my environment anymore, maybe it was fixed (I'm on FP CU5), I'm not sure.

I'm not sure but I think adding those projects to the AOT is optional. There is not a project for every report in AX so... If this is the case you could remove them from the AOT. If not, do a checkout of the project for that report and then sync with tfs.

Please provide an update if that was the problem. SSRS is not my specialty but I hope this helps.

Kind regards,


SomuAx2012 responded on 16 Feb 2014 8:59 AM


Thanks for you reply.

One of the reports i am receiving error is standard purchase order report(PurchPurchaseOrderReport) which we have customized.

There is already existing visual studio project for this report.

This does not happen when i compile the report. The latest report changes are not being imported with TFS sync. I have my TFS Sync log fully in incomplete state. I mean the complete checkbox in TFS sync log is not checked for all the items.

I tried to compile the report in other dev environments where the report was developed and checkedin from, it compliles ok. no errors.

Please help.

Klaas Deforche responded on 16 Feb 2014 9:18 AM


Your first priority should be to clean up your sync log. If you can, process everything by clicking the Process button in the synchronization log. You might have to process it multiple time. Until everything is processed, no new items will be imported.

You could also start anew by deleting the layer that contains your customization and by removing all items in the synchronization log. Followed by a force sync with TFS.

SomuAx2012 responded on 16 Feb 2014 10:32 AM

I have tried to process the sync log previously, but only once. I am now going to process it multiple times as you said.

When i try to checkout my ssrs report, it is failing with error message saying something like - the item has not been imported correctly in previous sync and cannot checkout.

Will try deleting the layer simultaneously on another box.

Will keep you posted. Thank you very much for all your ideas. Talked to microsoft people about this, but didi not get any useful response yet.

Delete the layer - Did you mean delete the models in the layer?

Sailaja Bondlela responded on 20 Feb 2014 12:46 PM

We are facing a similar issue on one of our development box. Were you able to fix. Also the synchronization log will not process thru.

SomuAx2012 responded on 20 Feb 2014 12:56 PM

I have been breaking my head on this issue for 10 days now.

After some research i found that compiling visual studio project corresponding to the report will also give the same error.

You can process the log by deleting the records related to visual studio projects> ax model projects from the log table.

Also try processing the log with your SSRS reports checked-out.

The reason behind this may be the fact that after importing the changes from local repository, AX tries to compile the objects it imported. When compiling the visual studio project it tries to write some information to corresponding SSRS reports, which are not editable because they are locked by TFS.

This problem most likely occurs only for the reports with their corresponding visual studio projects modified.

Sailaja Bondlela responded on 20 Feb 2014 7:46 PM

Thank you for the response. Following your approach it will compile the SSRS report and VS project, but in return It keeps popping the error on a different SSRS report. Also the synchronization log does not complete even after tying to process multiple times.

SomuAx2012 responded on 27 Feb 2014 9:44 AM

Were you able to fix this issue? I was able to move forward by restoring an old sql backup and then doing the TFS sync.

Did you find the solution?

AlexDAX responded on 12 Jan 2015 2:58 PM

I still need to investigate deeper on what causes this, but a quick resolution is to check out the SSRS report, then compile the Visual Studio Project, then check the SSRS report back in.  If you export the SSRS report to XPO before and after the check-in, you will see it gets a new RDL # (RDL 232436 for example) and that's pretty much the only change.