Error when configuring Management Reporter CU8 - An unexpected error occurred while querying the Metadata service

Question Status

DeftBat asked a question on 26 Mar 2014 12:59 PM


I have completed the installation of the Management Reporter CU8 Application and Process services.

However, when I try and configure the AX datamart it presents the following error message "An unexpected error occurred while querying the Metadata service".

I have set the AOS Service port = 8210 and AOS Port = 2712

The log is detailed below - I have checked the display name in AD is set for all the accounts.

I would be grateful for any pointers....



3/26/2014 7:56:20 PM - Verifying provided credentials for change tracking

3/26/2014 7:56:20 PM - Credentials for user  were successfully verified.

3/26/2014 7:56:20 PM - System.ServiceModel.FaultException`1[Microsoft.Dynamics.Performance.Deployment.DataProvider.AX.AX2012MetadataService.MetadataFault]: An exception of type MetdataException has occurred while performing the operation. (Fault Detail is equal to Microsoft.Dynamics.Performance.Deployment.DataProvider.AX.AX2012MetadataService.BatchFault).

Eyvindur Tryggvason responded on 26 Mar 2014 4:34 PM

Are you sure about 8210?  Defaults are 8201 and 2712, check if that might be the case.

Tim Rowe responded on 27 Mar 2014 1:24 AM

Thanks for coming back to me. My post was a typo and I have been trying to use 8201 (not 8210) as previously reported) along with 2712 etc and have this issue with the metaservice...

Any other ideas / thoughts would be most welcome...

Eyvindur Tryggvason responded on 27 Mar 2014 3:19 AM

Is the service definitely running?  You can check http://servername:8101/DynamicsAx/Services/MetadataService

Note that the default WSDL port is 8101 for the endpoint port 8201.

Dick Wenning responded on 27 Mar 2014 5:13 AM

is the user that collects the data also an user in ax?

Eyvindur Tryggvason responded on 27 Mar 2014 7:04 AM

Yes - has to be a user in AX.  Every AX user can access the MetaData service, but yes - has to be a user in AX.

Tim Rowe responded on 27 Mar 2014 8:03 AM
I believe so. When I enter that url, XML is returned.
Tim Rowe responded on 27 Mar 2014 8:04 AM

Yes - valid user in AX...

David Orr responded on 23 Sep 2014 7:02 PM

Did you ever resolve this issue?

I am getting the same error when upgrading from CU4 to CU5, connecting to AX2012RTM with CU3.

Michele Mattiuzzo responded on 5 Nov 2014 8:16 AM

Hi all, did you manage to find a solution?

I'm facing the same problem with Ax 2012 and MR 2012 RU5.

Thanks in advance,


prl responded on 19 Feb 2015 5:03 AM

Hi, did anyone solve this problem? I'm having exactly the same error. Account which I'm using has display name, it is admin on sql and aos server, in db and ax too, I use aos host server name, not the instance, CIL compiled without any errors. Any help would be much appreciated.

David Orr responded on 19 Feb 2015 2:19 PM

I tracked our problem down to relations on ProjTable that we had added to InventSite and InventLocation. As we found that we didn't need these relations, I removed them and the error went away. I found this out after talking to Microsoft support and using some of the diagnostic tools. These confirmed that the credentials were OK, but the tool that examines the tables unfortunately did not highlight the problem, so I had to look at what we had recently added to the tables that Management Reporter looks at, and found that the only recent addition was the 2 relations.

One of the tools (I can't remember what it was called) gives you a list of the tables that it looks at, so all you need to do is check those tables.