Packing slip posting through Shipments

Question Status

Suggested Answer
Kaushik Ramakrishna asked a question on 16 Jun 2017 9:47 AM

Hi All,

I am trying to post the packing slip through shipment screen in AX2012 R3 warehouse management. But it gives me a blank packing slip screen but this works when I open packing slip from sales order.

Here is the steps I am following:

1. Created  a Sales order->Release sales order for picking->Execute picking work through mobile device->Confirm the outbound shipment->Post the packing slip from shipment screen.

Can you please help me with this.

Reply
Sagar Suman responded on 16 Jun 2017 1:40 PM

Hi Kaushik,

What do you mean by blank packing slip screen. Do you mean some fields having blank data or nothing being displayed on the form at all.

Kindly share some more details about the form and it would be better if you can share the screenshot for the same.

Reply
Guy Terry responded on 19 Jun 2017 5:23 AM

Hi Kaushik,

What CU is this?

Reply
Nick Holden responded on 19 Jun 2017 3:29 PM

Hi Kaushik,

I have seen that behaviour while trying to generate packing slip but for transfer orders.

Have you tryed from the Load form? (your shipment should be related to a load, try it).

Reply
Crispin John Augustine responded on 20 Jun 2017 2:54 AM

Hi Kaushik,

One of the common reasons could be, your shipment is missing a Load. (without which you will get a blank report)

Could you confirm this, before looking at other possibilities?

Reply
Kaushik Ramakrishna responded on 21 Jun 2017 4:17 PM

We are on CU10. There was nothing on the packing slip screen when we were trying to post it. We debugged and found out that the location profile had a space. Not sure how it made it to the query but changing that solved the problem. Thank you guys.

Reply
david responded on 15 Jan 2018 12:50 AM

Hello Kaushik. what do you mean for "location profile had a space"?

actually I have same issue and I can't post my packingslip qty through shipment or load.

Reply
Suggested Answer
Fatih Gork responded on 15 Jan 2018 4:18 AM

Hi,

This functionality takes action only for transactions that have issue status of "Picked" and this is accomplished by completing the Whs work. It is all good until this point. However, the problem is connected with Location directive setups, Work templates, Warehouse management parameters and location master data.

To achieve the status of "Picked", you should have a location that has a location profile which has the location type that matches with the one specified in WhsParameters.ShipFinalLocType. 

If your last put line's location, has the location type mentioned in Whs Parameters as the final shipping location type, then: When you complete the work, inventory transactions will be updated as "Picked".

The packing slip button on shipment, works just like regular packing slip form chosed "Picked quantity" in update type. If your setups are not correct, your inventory status does not get updated. So stays as "Reserved physical" even tough you complete the work. Then the packing slip form, comes up empty. Because there is no picked quantity.

I hope that helps.

Reply
Guy Terry responded on 15 Jan 2018 4:20 AM

Hi david,

Do you get an error message?

Reply
david responded on 8 Feb 2018 4:53 AM

Hi Guy,

No I don't get any error message. if I use manuel packing process I can post my packing slip. when I don't use manuel packing process I Can't.

Reply
Suggested Answer
Sagar Suman responded on 13 Feb 2018 1:34 PM

Hi David,

What error do you get or why are you not able to post the packing slip from the shipment??

I have no issues in posting packing slip from the shipment and you can only do the same after shipment status changes to shipped.

Kindly make sure all the items in the sales order are picked and packed and more importantly all the items are in the same shipment.

Also make sure the shipment is confirmed and status is shipped before you try to post the packing slip.

Reply
Suggested Answer
Fatih Gork responded on 15 Jan 2018 4:18 AM

Hi,

This functionality takes action only for transactions that have issue status of "Picked" and this is accomplished by completing the Whs work. It is all good until this point. However, the problem is connected with Location directive setups, Work templates, Warehouse management parameters and location master data.

To achieve the status of "Picked", you should have a location that has a location profile which has the location type that matches with the one specified in WhsParameters.ShipFinalLocType. 

If your last put line's location, has the location type mentioned in Whs Parameters as the final shipping location type, then: When you complete the work, inventory transactions will be updated as "Picked".

The packing slip button on shipment, works just like regular packing slip form chosed "Picked quantity" in update type. If your setups are not correct, your inventory status does not get updated. So stays as "Reserved physical" even tough you complete the work. Then the packing slip form, comes up empty. Because there is no picked quantity.

I hope that helps.

Reply
Suggested Answer
Sagar Suman responded on 13 Feb 2018 1:34 PM

Hi David,

What error do you get or why are you not able to post the packing slip from the shipment??

I have no issues in posting packing slip from the shipment and you can only do the same after shipment status changes to shipped.

Kindly make sure all the items in the sales order are picked and packed and more importantly all the items are in the same shipment.

Also make sure the shipment is confirmed and status is shipped before you try to post the packing slip.

Reply