SBX - Search With Button

SBX - Forum Post Title

ISV package installation failes

Microsoft Dynamics AX Forum

Johnny Almeida asked a question on 9 Jul 2018 5:43 AM
My Badges

Question Status

Suggested Answer

Hello,

Have tried to install ISV package from library.

It failed with this error "The specified module 'C:\Program Files\Microsoft Security Client\MpProvider' was not loaded because no valid module file was found in any module directory"

Has anyone encounter this error message? Google does not give to much info.

Thanks.

Reply
Palle Agermark responded on 10 Jul 2018 1:52 AM
My Badges
Suggested Answer

I know that André Arnaud de Calavon had this error on an installation. He was advised from Microsoft to:

"... check what the powershell execution policy is on those machines?

it should be

CurrentUser - RemoteSigned

LocalMachine - RemoteSigned

and rest as Undefined"

I'm afraid that's all I know about the issue.

Reply
Johnny Almeida responded on 10 Jul 2018 11:09 AM
My Badges

Thanks Palle for your reply.

Unfortunetelly this did not help.

Reply

Hi Johnny,

During a test on a preview of a platform update, I got the same error when I wanted to install the PU preview. It was something that was wrong at the Microsoft side which was quickly found and fixed.

Can you tell what exactly you are trying to install? On what deployment are you installing this ISV solution? What PU version? What application version? Azure or on-premise? Is the deployable package of the ISV solution compatible with your environment?

Reply
Johnny Almeida responded on 11 Jul 2018 4:44 AM
My Badges

Hello Andre,

It's PU15, Application version is (July 2017). I try to install ISV on on-premise.

It should be compitable, because it's already installed on another boxes with same version.

Could it be caused by not installed Windows updates?

Thanks.

Reply

Hi Johnny,

Was it installed on another on-premise environment before, or an Azure hosted environment?

Possibly, you can better contact Microsoft support to get help on this.

Reply
vinod Bhandari responded on 13 Oct 2018 3:59 PM
My Badges
Suggested Answer

Hi,

I have faced same error while applying Platform Update 20 on one of our environment. In our case the visual studio was opened on UAT server at the time of applying the Update.

I was able to apply the Update after closing the Visual Studio on the server.

Regards,

Vinod Bhandari

Reply
Palle Agermark responded on 10 Jul 2018 1:52 AM
My Badges
Suggested Answer

I know that André Arnaud de Calavon had this error on an installation. He was advised from Microsoft to:

"... check what the powershell execution policy is on those machines?

it should be

CurrentUser - RemoteSigned

LocalMachine - RemoteSigned

and rest as Undefined"

I'm afraid that's all I know about the issue.

Reply
vinod Bhandari responded on 13 Oct 2018 3:59 PM
My Badges
Suggested Answer

Hi,

I have faced same error while applying Platform Update 20 on one of our environment. In our case the visual studio was opened on UAT server at the time of applying the Update.

I was able to apply the Update after closing the Visual Studio on the server.

Regards,

Vinod Bhandari

Reply

SBX - Two Col Forum

SBX - Migrated JS