SBX - Search With Button

SBX - Forum Post Title

AOS installation issue

Microsoft Dynamics AX Forum

Matti Kärnä asked a question on 12 Oct 2011 2:39 AM
My Badges

Question Status

Verified

Hi!

We are installing AX 2012 as part of a school project. We are using virtual machines. The database installed fine but when we try to install AOS into a different computer (server 2008r2 and in the same domain) we encounter problems. The installer says that everything succeeded but in the log file as it is granting the domain account access to the database it says network path not found. If we check from the SQL Server it has created the logins and users but hasn't granted securables to the baseline user. If we install the AOS on the same computer as the SQL it works fine and we have disabled the firewall and the machines can ping each other. We are also slipstreaming the CU1. Sorry for long post but we are puzzled...

Here is the log file:


2011-10-12 15:13:11Z    === Setting up Application Object Server (AOS) ===
2011-10-12 15:13:11Z    Adding account 'axint\axservice' as a login in Microsoft SQL Server.
2011-10-12 15:13:12Z    isolation level = read committed snapshot
2011-10-12 15:13:12Z    Adding account 'axint\axservice' as a login in Microsoft SQL Server.
2011-10-12 15:13:12Z    Adding account 'axint\axservice' as a login in Microsoft SQL Server.
2011-10-12 15:13:12Z    Granting AOS account access to database MicrosoftDynamicsAX on server AXSQL
2011-10-12 15:13:13Z    ******************************************************************************************************

2011-10-12 15:13:13Z    Component installation task stopped due to an error.

2011-10-12 15:13:13Z    ******************************************************************************************************
2011-10-12 15:13:13Z    ******************************************************************************************************

2011-10-12 15:13:13Z    The network path was not found.


2011-10-12 15:13:13Z    ******************************************************************************************************
2011-10-12 15:13:13Z    ******************************************************************************************************

2011-10-12 15:13:13Z    System.IO.IOException: The network path was not found.

2011-10-12 15:13:13Z       at Microsoft.Win32.RegistryKey.Win32ErrorStatic(Int32 errorCode, String str)
2011-10-12 15:13:13Z       at Microsoft.Win32.RegistryKey.OpenRemoteBaseKey(RegistryHive hKey, String machineName)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.GetEventLogRegKey(String machine, Boolean writable)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.FindSourceRegistration(String source, String machineName, Boolean readOnly)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.SourceExists(String source, String machineName)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.VerifyAndCreateSource(String sourceName, String currentMachineName)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.WriteEntry(String message, EventLogEntryType type, Int32 eventID, Int16 category, Byte[] rawData)
2011-10-12 15:13:13Z       at System.Diagnostics.EventLog.WriteEntry(String message, EventLogEntryType type, Int32 eventID)
2011-10-12 15:13:13Z       at Microsoft.Dynamics.AX.Framework.Tools.ModelManagement.AxUtilEventLog.Log(EventLogEntryType eventLogType, AxUtilEventLogType logType, String message)
2011-10-12 15:13:13Z       at Microsoft.Dynamics.AX.Framework.Tools.ModelManagement.AxUtilEventLog.LogSuccess(AxUtil util, AxUtilEventLogType eventLogType, AxUtilAction action, IAxUtilEventLogEntry logEntry)
2011-10-12 15:13:13Z       at Microsoft.Dynamics.AX.Framework.Tools.ModelManagement.AxUtil.GrantPermission(String schemaName)
2011-10-12 15:13:13Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.AOSInstaller.GrantAOSAccounttoDatabase(String databaseServer, String databaseName)
2011-10-12 15:13:13Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.AOSInstaller.AosPreInstallActions()
2011-10-12 15:13:13Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.AOSInstaller.PerformWork()
2011-10-12 15:13:13Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.InstallationClass.DoWork(Object sender, DoWorkEventArgs e)
2011-10-12 15:13:13Z       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

2011-10-12 15:13:13Z    ******************************************************************************************************
2011-10-12 15:13:14Z    S260FinishedInfo

Reply
Matti Kärnä responded on 11 Jan 2012 11:19 PM
My Badges
Verified Answer

So in the end we solved this by accident. The SQL Server machine didn't have the  Remote Registry service running. We started that and the installation went like a charm.

Reply
Pierre Louis responded on 23 Apr 2013 2:39 AM

I have same error message, but starting the remote Registry service on the SQL Server machine did not solve my problem.

Reply
Pierre Louis responded on 23 Apr 2013 4:14 AM

In my case, the "Firewall" on the SQL server was still blocking the remote registry. Needed to allow access from the AOS server trough the firewall to access the remote registry Service" .

Reply
Matt Ther responded on 7 Aug 2013 1:52 AM
My Badges

hi Pierre,

1) How yo allow the access from the AOS server?

2) I have off the firewall and started the remote registry, but it is still the same.  any clue?

Reply
Matti Kärnä responded on 11 Jan 2012 11:19 PM
My Badges
Verified Answer

So in the end we solved this by accident. The SQL Server machine didn't have the  Remote Registry service running. We started that and the installation went like a charm.

Reply

SBX - Two Col Forum

SBX - Migrated JS