How to delete Model

This question is answered

Hi guys,

I tried to create Model in Ax 2012, let say named MyfirstModel. I can see my model from Tools > Model Management > Model Installed. Question is how to delete it ?

 I went to Dynamics Power shell, run get-axmodel -layer usr, but only return 1 model which is the standard usr layer model itself (I guess that's why I cannot delete my model with command unisntall-axmodel -model MyfirstModel at first).

I'm still learning this, so kindly help. Thanks.

Verified Answer
All Replies
  • Hi,Please follow this link which might helps you:

    technet.microsoft.com/.../hh433514.aspx

    Regards,

    Vikash

  • Hi Vikash,

    Thanks for your reply, and yes that is where I got the command in Power Shell. I also try using AXUtil. The reason it cannot be deleted, because even when I try to list it to see how many Models there are, it shows me only one, Standard USR model.

    Regards,

  • Hi Anton,

    There is ability to specify the database and server name in the axutil command. Try to use something like this to list your models:

    axutil list /s:server name /DB:Database name

    Thanks,

    Rachit Garg

    http://axrachit.blogspot.in/

  • Hi Rachit,

    Thanks, you are right. It turned out my model is inside another database. And this database is the one which my DynamicsAX2012 used.

    Now my question is how to delete that model since AxUtil, especially AxUtil delete do not have parameter to specify database. Kindly advise.

    Thanks again.

  • PowerShell cmdlet Uninstall-AXModel supports parameters -Server and -Database and I believe that you can use parameters /s and /db even with axutil delete.

    Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

  • Hi Martin,

    Thanks. It worked. Didn't thought that those parameters can be used in all AxUtil command, my bad.  

    Thanks again for all others for kind help.

    Regards,