DMF Duplicate assignment found for the following target field

This question has suggested answer(s)

I have installed DMF 2.0, I created new custom entity for Employee and created a new method 'GenerateWorkerTitle' after I modified target mapping by adding new record then I switch to design mode(preview mapping) the relation is not created.

after that I closed, and when tried to open Modify Target Mapping again popped up error : Duplicate assignment found for the following target field  'GenerateWorkerTitle'.

How to resolve this? acctually it is not duplicate cos I created new entity and only have 1 GenerateWorkerTitle

All Replies
  • I had the same problem, to get around it, I deleted the record for the new 'Generate' method from table DMFTargetXMLToEntityMap. But once I added the mapping back in, I got the same error. I then switched to the graphical mapping screen and noticed that my method was not showing up.

    Turns out you need to add a fieldGroup to the table with the same name as the method. Once I did that, the method showed up and I could to the mapping

    Rob.

  • Yeah! It also worked for me. It should be nice that they provide step by step guide of things like that if they want people to start using it instead of losing your time