KPI Error messages within Role Center of Enterprise Portal

Question Status

Christopher Rice asked a question on 26 Dec 2012 11:29 AM


We have AX 2009 and just deployed Enterprise Portal.  I have so far processed the Customer Relationship Management Cube and the General Ledger Cube.  For both the financial and customer KPIs, I receive the error message The dimension '[Master Company Reporting Currency]' was not found in the cube when the string, [Master Company Reporting Currency].Currentcy],&[Local], was parsed.  Everything from as far as I can see for the two cubes processed fine through Business Intelligence Development Studio.  Any ideas?

Adrian Pascari A responded on 27 Dec 2012 5:09 AM

Administration->SetUp->Business Analysis->OLAP->Setup exchange rates.

After depoy your cubes again and reproccess .

Christopher Rice responded on 27 Dec 2012 5:22 AM

When I go to setup exchange rates, I see the following:

Use the exchange rates from this company: DAT

Exchange rate master currency is blank and greyed out.

I check populate exchange rates now and click ok, but it doesn't appear to do anything.  I'm assuming the information above is not normal?

Christopher Rice responded on 27 Dec 2012 5:49 AM

I logged into the AOS server and did find the valid company and the Exchange Rate showed up as well and I went through the process.  I did reprocess the cubes and still receive the same error message in role center.

Adrian Pascari A responded on 27 Dec 2012 5:56 AM

Then I don't know how to solve the problem. What kpi(on what rolecenter page and name of the kpi) is returning this error? I'll try to check this kpi in my enviroment to see what it is trying to calculate.

Christopher Rice responded on 27 Dec 2012 6:02 AM

It is the CEO Role Center Page.  The two KPIs are Financial and Customer

Lalit Jivnani responded on 21 Feb 2013 5:11 AM

have you got the solution for the above error ??

please respond me as i am in urgent need for the solution

Christopher Rice responded on 21 Feb 2013 5:18 AM

Yes.  The Master Company Reporting Currency dimension was not added to the cube.  Once I added that it worked.  I don't recall if there was anything else involved other then adding that dimension to the cubes.

Tommy Skaue responded on 24 Feb 2013 12:56 AM

You should mark your answer as accepted answer in order to mark this thread as "answered" :)